summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-servers/pathod/pathod-0.9.1.ebuild')
-rw-r--r--www-servers/pathod/pathod-0.9.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/www-servers/pathod/pathod-0.9.1.ebuild b/www-servers/pathod/pathod-0.9.1.ebuild
new file mode 100644
index 000000000000..c3f3beb9f89a
--- /dev/null
+++ b/www-servers/pathod/pathod-0.9.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/pathod/pathod-0.9.1.ebuild,v 1.1 2013/06/17 06:49:58 radhermit Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="A collection of pathological tools for testing and torturing HTTP clients and servers"
+HOMEPAGE="https://github.com/cortesi/pathod/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=">=dev-python/netlib-0.9[${PYTHON_USEDEP}]
+ >=dev-python/requests-1.1.0[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+RESTRICT="test"
+
+python_test() {
+ nosetests -v || die "Tests fail with ${EPYTHON}"
+}