summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs/libXfont/libXfont-1.2.5.ebuild')
-rw-r--r--x11-libs/libXfont/libXfont-1.2.5.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/x11-libs/libXfont/libXfont-1.2.5.ebuild b/x11-libs/libXfont/libXfont-1.2.5.ebuild
new file mode 100644
index 000000000000..fdc4b5ab1dbb
--- /dev/null
+++ b/x11-libs/libXfont/libXfont-1.2.5.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libXfont/libXfont-1.2.5.ebuild,v 1.1 2006/12/02 16:20:53 joshuabaergen Exp $
+
+# Must be before x-modular eclass is inherited
+# SNAPSHOT="yes"
+
+inherit x-modular flag-o-matic
+
+DESCRIPTION="X.Org Xfont library"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="ipv6"
+
+RDEPEND="x11-libs/xtrans
+ x11-libs/libfontenc
+ x11-proto/xproto
+ x11-proto/fontsproto
+ >=media-libs/freetype-2"
+DEPEND="${RDEPEND}
+ x11-proto/fontcacheproto"
+
+CONFIGURE_OPTIONS="$(use_enable ipv6)
+ --with-encodingsdir=/usr/share/fonts/encodings"
+
+pkg_setup() {
+ # No such function yet
+ # x-modular_pkg_setup
+
+ # (#125465) Broken with Bdirect support
+ filter-flags -Wl,-Bdirect
+ filter-ldflags -Bdirect
+ filter-ldflags -Wl,-Bdirect
+}