summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs/pixman/pixman-0.29.2.ebuild')
-rw-r--r--x11-libs/pixman/pixman-0.29.2.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/x11-libs/pixman/pixman-0.29.2.ebuild b/x11-libs/pixman/pixman-0.29.2.ebuild
new file mode 100644
index 000000000000..3ca0c324d45a
--- /dev/null
+++ b/x11-libs/pixman/pixman-0.29.2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/pixman/pixman-0.29.2.ebuild,v 1.1 2013/01/31 05:50:09 mattst88 Exp $
+
+EAPI=4
+inherit xorg-2 toolchain-funcs versionator
+
+EGIT_REPO_URI="git://anongit.freedesktop.org/git/pixman"
+DESCRIPTION="Low-level pixel manipulation routines"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
+IUSE="altivec iwmmxt mmx neon sse2"
+
+src_configure() {
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_enable mmx)
+ $(use_enable sse2)
+ $(use_enable altivec vmx)
+ $(use_enable neon arm-neon)
+ $(use_enable iwmmxt arm-iwmmxt)
+ --disable-gtk
+ )
+ xorg-2_src_configure
+}