summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs/scw/scw-0.4.7.ebuild')
-rw-r--r--x11-libs/scw/scw-0.4.7.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/x11-libs/scw/scw-0.4.7.ebuild b/x11-libs/scw/scw-0.4.7.ebuild
new file mode 100644
index 000000000000..3517b792d001
--- /dev/null
+++ b/x11-libs/scw/scw-0.4.7.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/scw/scw-0.4.7.ebuild,v 1.1 2007/03/06 16:16:34 ticho Exp $
+
+DESCRIPTION="A GTK+ widget set specifically designed for chat programs."
+HOMEPAGE="http://scwwidgets.googlepages.com"
+SRC_URI="http://scwwidgets.googlepages.com/${P}.tar.gz"
+LICENSE="LGPL-2"
+SLOT="0"
+
+KEYWORDS="~x86"
+IUSE="doc"
+RDEPEND="dev-util/pkgconfig
+ >=dev-libs/glib-2.4
+ >=x11-libs/gtk+-2.4"
+DEPEND="${RDEPEND}
+ doc? ( >=dev-util/gtk-doc-1 )"
+
+src_compile() {
+ econf $(use_enable doc gtk-doc) || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc README NEWS ChangeLog AUTHORS
+}