summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/xsetleds')
-rw-r--r--x11-misc/xsetleds/ChangeLog11
-rw-r--r--x11-misc/xsetleds/files/xsetleds-0.1.3-assignment.patch11
-rw-r--r--x11-misc/xsetleds/files/xsetleds-0.1.3-isalpha.patch13
-rw-r--r--x11-misc/xsetleds/xsetleds-0.1.3-r1.ebuild34
-rw-r--r--x11-misc/xsetleds/xsetleds-0.1.3.ebuild30
5 files changed, 87 insertions, 12 deletions
diff --git a/x11-misc/xsetleds/ChangeLog b/x11-misc/xsetleds/ChangeLog
index 8a11314ec44a..e2aedb46bb0e 100644
--- a/x11-misc/xsetleds/ChangeLog
+++ b/x11-misc/xsetleds/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-misc/xsetleds
-# Copyright 2000-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xsetleds/ChangeLog,v 1.16 2013/03/17 16:13:46 hwoarang Exp $
+# Copyright 2000-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xsetleds/ChangeLog,v 1.17 2014/09/03 09:03:56 jer Exp $
+
+*xsetleds-0.1.3-r1 (03 Sep 2014)
+
+ 03 Sep 2014; Jeroen Roovers <jer@gentoo.org> xsetleds-0.1.3.ebuild,
+ +xsetleds-0.1.3-r1.ebuild, +files/xsetleds-0.1.3-assignment.patch,
+ +files/xsetleds-0.1.3-isalpha.patch:
+ einstall -> EAPI 5 default (bug #521674). Respect CC. Fix some coding issues.
17 Mar 2013; Markos Chandras <hwoarang@gentoo.org> metadata.xml:
Add proxy-maintainers to metadata.xml
diff --git a/x11-misc/xsetleds/files/xsetleds-0.1.3-assignment.patch b/x11-misc/xsetleds/files/xsetleds-0.1.3-assignment.patch
new file mode 100644
index 000000000000..bc929813a3fc
--- /dev/null
+++ b/x11-misc/xsetleds/files/xsetleds-0.1.3-assignment.patch
@@ -0,0 +1,11 @@
+--- a/src/utils.c
++++ b/src/utils.c
+@@ -38,7 +38,7 @@
+ {
+ const char *p;
+
+- if (p = strrchr (filename, '/'))
++ if ((p = strrchr (filename, '/')))
+ p = strrchr (filename, '/') + 1;
+ else
+ p = filename;
diff --git a/x11-misc/xsetleds/files/xsetleds-0.1.3-isalpha.patch b/x11-misc/xsetleds/files/xsetleds-0.1.3-isalpha.patch
new file mode 100644
index 000000000000..b256bdb2da66
--- /dev/null
+++ b/x11-misc/xsetleds/files/xsetleds-0.1.3-isalpha.patch
@@ -0,0 +1,13 @@
+--- a/src/xsetleds.c
++++ b/src/xsetleds.c
+@@ -29,8 +29,9 @@
+ #include <string.h>
+ #include <stdlib.h>
+ #include <stdarg.h>
++#include <ctype.h> /* isalpha() */
+
+-#include <xsetleds.h>
++#include "xsetleds.h"
+
+
+ struct key keytab[] = {
diff --git a/x11-misc/xsetleds/xsetleds-0.1.3-r1.ebuild b/x11-misc/xsetleds/xsetleds-0.1.3-r1.ebuild
new file mode 100644
index 000000000000..1c846ed8906f
--- /dev/null
+++ b/x11-misc/xsetleds/xsetleds-0.1.3-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xsetleds/xsetleds-0.1.3-r1.ebuild,v 1.1 2014/09/03 09:03:56 jer Exp $
+
+EAPI=5
+inherit eutils toolchain-funcs
+
+DESCRIPTION="small tool to report and change the keyboard LED states of an X display"
+HOMEPAGE="ftp://ftp.unix-ag.org/user/bmeurer/xsetleds/"
+SRC_URI="ftp://ftp.unix-ag.org/user/bmeurer/xsetleds/src/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~sparc ~x86"
+
+RDEPEND="
+ x11-libs/libX11
+ x11-libs/libXtst
+"
+DEPEND="
+ ${RDEPEND}
+ x11-proto/inputproto
+ x11-proto/xextproto
+ x11-proto/xproto
+"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-assignment.patch \
+ "${FILESDIR}"/${P}-isalpha.patch
+ tc-export CC
+}
+
+DOCS=( AUTHORS ChangeLog README TODO )
diff --git a/x11-misc/xsetleds/xsetleds-0.1.3.ebuild b/x11-misc/xsetleds/xsetleds-0.1.3.ebuild
index 277bd89da7a1..6f06f623d1c8 100644
--- a/x11-misc/xsetleds/xsetleds-0.1.3.ebuild
+++ b/x11-misc/xsetleds/xsetleds-0.1.3.ebuild
@@ -1,6 +1,9 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xsetleds/xsetleds-0.1.3.ebuild,v 1.16 2008/01/07 10:42:10 nelchael Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xsetleds/xsetleds-0.1.3.ebuild,v 1.17 2014/09/03 09:03:56 jer Exp $
+
+EAPI=5
+inherit eutils toolchain-funcs
DESCRIPTION="small tool to report and change the keyboard LED states of an X display"
HOMEPAGE="ftp://ftp.unix-ag.org/user/bmeurer/xsetleds/"
@@ -9,16 +12,23 @@ SRC_URI="ftp://ftp.unix-ag.org/user/bmeurer/xsetleds/src/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86 ppc sparc alpha hppa ~mips amd64 ia64"
-IUSE=""
-RDEPEND="x11-libs/libX11
- x11-libs/libXtst"
-DEPEND="${RDEPEND}
+RDEPEND="
+ x11-libs/libX11
+ x11-libs/libXtst
+"
+DEPEND="
+ ${RDEPEND}
x11-proto/inputproto
x11-proto/xextproto
- x11-proto/xproto"
+ x11-proto/xproto
+"
-src_install() {
- einstall || die
- dodoc AUTHORS ChangeLog README TODO
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-assignment.patch \
+ "${FILESDIR}"/${P}-isalpha.patch
+ tc-export CC
}
+
+DOCS=( AUTHORS ChangeLog README TODO )