summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/desklet-ltvariations/desklet-ltvariations-0.21.ebuild')
-rw-r--r--x11-plugins/desklet-ltvariations/desklet-ltvariations-0.21.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/x11-plugins/desklet-ltvariations/desklet-ltvariations-0.21.ebuild b/x11-plugins/desklet-ltvariations/desklet-ltvariations-0.21.ebuild
new file mode 100644
index 000000000000..49ed8ff7be7c
--- /dev/null
+++ b/x11-plugins/desklet-ltvariations/desklet-ltvariations-0.21.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/desklet-ltvariations/desklet-ltvariations-0.21.ebuild,v 1.1 2003/09/28 06:07:34 obz Exp $
+
+DESKLET_NAME="LTVariations"
+
+MY_P=${DESKLET_NAME}-${PV}
+S=${WORKDIR}
+
+DESCRIPTION="The clock sensors and displays for gdesklets"
+SRC_URI="http://gdesklets.gnomedesktop.org/files/${MY_P}.tgz"
+HOMEPAGE="http://www.pycage.de/"
+LICENSE="as-is"
+
+SLOT="0"
+IUSE=""
+KEYWORDS="~x86"
+
+DEPEND=">=gnome-extra/gdesklets-core-0.22
+ >=x11-plugins/desklet-weather-0.21"
+
+src_install( ) {
+
+ SYS_PATH="/usr/share/gdesklets"
+ dodir ${SYS_PATH}/{Sensors,Displays}
+
+ # the LTV Sensors
+ cd ${S}/LTV\ Sensors/
+ for i in `ls *.bin`; do
+ python ${i} --nomsg ${D}${SYS_PATH}/Sensors
+ done
+
+ # and apparently we need the iconbutton sensor as well
+ cd ${S}/Other\ Sensors/
+ python Install_IconButton_Sensor.bin --nomsg ${D}/${SYS_PATH}/Sensors
+
+ cd ${S}/LTCandy
+ # and then the .displays
+ insinto ${SYS_PATH}/Displays/${DESKLET_NAME}
+ doins *.display
+
+ # and finally the graphics, and their messed up permissions fix
+ cp -R gfx/ ${D}${SYS_PATH}/Displays/${DESKLET_NAME}
+ chmod 644 ${D}${SYS_PATH}/Displays/${DESKLET_NAME}/gfx/*.png
+
+}
+