summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/pidgin-encryption/pidgin-encryption-3.0.ebuild')
-rw-r--r--x11-plugins/pidgin-encryption/pidgin-encryption-3.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/x11-plugins/pidgin-encryption/pidgin-encryption-3.0.ebuild b/x11-plugins/pidgin-encryption/pidgin-encryption-3.0.ebuild
new file mode 100644
index 000000000000..44a4e9a80683
--- /dev/null
+++ b/x11-plugins/pidgin-encryption/pidgin-encryption-3.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-encryption/pidgin-encryption-3.0.ebuild,v 1.1 2007/05/09 13:14:06 tester Exp $
+
+inherit flag-o-matic eutils
+
+DESCRIPTION="Pidgin IM Encryption PlugIn"
+HOMEPAGE="http://gaim-encryption.sourceforge.net/"
+SRC_URI="mirror://sourceforge/gaim-encryption/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="nls"
+
+
+RDEPEND="net-im/pidgin
+ >=x11-libs/gtk+-2
+ >=dev-libs/nss-3.11"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_compile() {
+ strip-flags
+ replace-flags -O? -O2
+ econf $(use_enable nls) || die "failed running configure"
+ emake -j1 || die "Make failed"
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die "Install failed"
+ dodoc CHANGELOG INSTALL NOTES README TODO VERSION WISHLIST
+}