summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'xfce-extra/transd/transd-0_p20110501.ebuild')
-rw-r--r--xfce-extra/transd/transd-0_p20110501.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/xfce-extra/transd/transd-0_p20110501.ebuild b/xfce-extra/transd/transd-0_p20110501.ebuild
new file mode 100644
index 000000000000..3b20eee7a27e
--- /dev/null
+++ b/xfce-extra/transd/transd-0_p20110501.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/transd/transd-0_p20110501.ebuild,v 1.1 2011/05/01 11:48:08 ssuominen Exp $
+
+EAPI=4
+EAUTORECONF=yes
+EINTLTOOLIZE=yes
+inherit xfconf
+
+DESCRIPTION="A small daemon to watch for window creation and set window transparency values"
+HOMEPAGE="http://spuriousinterrupt.org/projects/transd"
+SRC_URI="http://dev.gentoo.org/~ssuominen/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ >=xfce-base/libxfcegui4-4.8"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ dev-util/pkgconfig"
+
+pkg_setup() {
+ DOCS=( AUTHORS README TODO )
+}
+
+src_prepare() {
+ sed -i -e '/Encoding/d' transd.desktop.in || die
+ xfconf_src_prepare
+}