summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'xfce-extra/xfce4-linelight-plugin/xfce4-linelight-plugin-0.1.6-r1.ebuild')
-rw-r--r--xfce-extra/xfce4-linelight-plugin/xfce4-linelight-plugin-0.1.6-r1.ebuild24
1 files changed, 11 insertions, 13 deletions
diff --git a/xfce-extra/xfce4-linelight-plugin/xfce4-linelight-plugin-0.1.6-r1.ebuild b/xfce-extra/xfce4-linelight-plugin/xfce4-linelight-plugin-0.1.6-r1.ebuild
index 6968d90a3428..e5c503147b33 100644
--- a/xfce-extra/xfce4-linelight-plugin/xfce4-linelight-plugin-0.1.6-r1.ebuild
+++ b/xfce-extra/xfce4-linelight-plugin/xfce4-linelight-plugin-0.1.6-r1.ebuild
@@ -1,25 +1,27 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-linelight-plugin/xfce4-linelight-plugin-0.1.6-r1.ebuild,v 1.4 2011/01/29 20:58:14 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-linelight-plugin/xfce4-linelight-plugin-0.1.6-r1.ebuild,v 1.5 2011/05/19 20:37:31 ssuominen Exp $
-EAPI=3
+EAPI=4
EAUTORECONF=yes
inherit xfconf
-DESCRIPTION="a simple frontend for the locate search"
-HOMEPAGE="http://goodies.xfce.org/projects/panel-plugins/xfce4-linelight-plugin/"
+DESCRIPTION="A simple locate based search plug-in for the Xfce panel"
+HOMEPAGE="http://goodies.xfce.org/projects/panel-plugins/xfce4-linelight-plugin"
SRC_URI="mirror://xfce/src/panel-plugins/${PN}/0.1/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="amd64 ~x86"
+KEYWORDS="amd64 x86"
IUSE=""
-RDEPEND=">=xfce-base/xfce4-panel-4.4
- >=xfce-base/libxfcegui4-4.4
+COMMON_DEPEND=">=xfce-base/xfce4-panel-4.8
+ >=xfce-base/libxfcegui4-4.8
>=x11-libs/gtk+-2.12:2
>=dev-libs/glib-2.18:2"
-DEPEND="${RDEPEND}
+RDEPEND="${COMMON_DEPEND}
+ sys-apps/mlocate"
+DEPEND="${COMMON_DEPEND}
dev-util/pkgconfig
sys-devel/gettext"
@@ -29,9 +31,5 @@ pkg_setup() {
"${FILESDIR}"/${P}-port-to-gio.patch
)
- XFCONF=(
- --disable-dependency-tracking
- )
-
- DOCS="AUTHORS ChangeLog NEWS"
+ DOCS=( AUTHORS ChangeLog NEWS )
}