summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'xfce-extra')
-rw-r--r--xfce-extra/xfce4-whiskermenu-plugin/ChangeLog10
-rw-r--r--xfce-extra/xfce4-whiskermenu-plugin/xfce4-whiskermenu-plugin-1.5.0.ebuild66
2 files changed, 74 insertions, 2 deletions
diff --git a/xfce-extra/xfce4-whiskermenu-plugin/ChangeLog b/xfce-extra/xfce4-whiskermenu-plugin/ChangeLog
index 0bf4613d098b..f51b9e7e27c9 100644
--- a/xfce-extra/xfce4-whiskermenu-plugin/ChangeLog
+++ b/xfce-extra/xfce4-whiskermenu-plugin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for xfce-extra/xfce4-whiskermenu-plugin
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-whiskermenu-plugin/ChangeLog,v 1.22 2014/07/01 12:27:20 hasufell Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-whiskermenu-plugin/ChangeLog,v 1.23 2015/04/12 20:06:58 mgorny Exp $
+
+*xfce4-whiskermenu-plugin-1.5.0 (12 Apr 2015)
+
+ 12 Apr 2015; Michał Górny <mgorny@gentoo.org>
+ +xfce4-whiskermenu-plugin-1.5.0.ebuild:
+ Version bump with a lot of fixes.
*xfce4-whiskermenu-plugin-1.4.0 (01 Jul 2014)
diff --git a/xfce-extra/xfce4-whiskermenu-plugin/xfce4-whiskermenu-plugin-1.5.0.ebuild b/xfce-extra/xfce4-whiskermenu-plugin/xfce4-whiskermenu-plugin-1.5.0.ebuild
new file mode 100644
index 000000000000..af7aba6b9e26
--- /dev/null
+++ b/xfce-extra/xfce4-whiskermenu-plugin/xfce4-whiskermenu-plugin-1.5.0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-whiskermenu-plugin/xfce4-whiskermenu-plugin-1.5.0.ebuild,v 1.1 2015/04/12 20:06:58 mgorny Exp $
+
+EAPI=5
+
+inherit gnome2-utils cmake-utils
+
+DESCRIPTION="Alternate application launcher for Xfce"
+HOMEPAGE="http://gottcode.org/xfce4-whiskermenu-plugin/"
+SRC_URI="http://gottcode.org/xfce4-whiskermenu-plugin/${P}-src.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+RDEPEND="
+ x11-libs/gtk+:2=
+ xfce-base/exo:=
+ xfce-base/garcon:=
+ xfce-base/libxfce4ui:=
+ xfce-base/libxfce4util:=
+ xfce-base/xfce4-panel:=
+ virtual/libintl:="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ sys-devel/gettext"
+
+src_prepare() {
+ local i
+ cd po || die
+ if [[ -n "${LINGUAS+x}" ]] ; then
+ for i in *.po ; do
+ einfo "removing ${i%.po} linguas"
+ has ${i%.po} ${LINGUAS} || { rm ${i} || die ; }
+ done
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_AS_NEEDED=OFF
+ -DENABLE_LINKER_OPTIMIZED_HASH_TABLES=OFF
+ -DENABLE_DEVELOPER_MODE=OFF
+ )
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ dodoc ChangeLog NEWS README
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}