summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2021-04-12 21:41:30 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2021-04-12 21:41:30 +0200
commit366449265349805228649e2fedca9ad2bc77b72a (patch)
treeee7da6482f06ea30478a022732cc418bb4febab1 /net-misc
parentnet-misc/xrdp: start bump and cleanup, wip (diff)
downloaddilfridge-366449265349805228649e2fedca9ad2bc77b72a.tar.gz
dilfridge-366449265349805228649e2fedca9ad2bc77b72a.tar.bz2
dilfridge-366449265349805228649e2fedca9ad2bc77b72a.zip
net-misc/xrdp: More cleanup
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/xrdp/files/xrdp-0.8.0-crypt-null-return.patch36
-rw-r--r--net-misc/xrdp/xrdp-0.9.15.ebuild28
2 files changed, 6 insertions, 58 deletions
diff --git a/net-misc/xrdp/files/xrdp-0.8.0-crypt-null-return.patch b/net-misc/xrdp/files/xrdp-0.8.0-crypt-null-return.patch
deleted file mode 100644
index 4454390..0000000
--- a/net-misc/xrdp/files/xrdp-0.8.0-crypt-null-return.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-From 851c762ee722a84d15348b2512b3b578282e590b Mon Sep 17 00:00:00 2001
-From: Jay Sorg <jay.sorg@gmail.com>
-Date: Wed, 29 Oct 2014 17:54:11 -0700
-Subject: [PATCH] sesman: check for null from crypt()
-
----
- sesman/verify_user.c | 9 +++++++--
- 1 file changed, 7 insertions(+), 2 deletions(-)
-
-diff --git a/sesman/verify_user.c b/sesman/verify_user.c
-index 98d3dd3..49c475c 100644
---- a/sesman/verify_user.c
-+++ b/sesman/verify_user.c
-@@ -51,6 +51,7 @@ long DEFAULT_CC
- auth_userpass(char *user, char *pass, int *errorcode)
- {
- const char *encr;
-+ const char *epass;
- struct passwd *spw;
- struct spwd *stp;
-
-@@ -84,8 +85,12 @@ auth_userpass(char *user, char *pass, int *errorcode)
- /* old system with only passwd */
- encr = spw->pw_passwd;
- }
--
-- return (strcmp(encr, crypt(pass, encr)) == 0);
-+ epass = crypt(pass, encr);
-+ if (epass == 0)
-+ {
-+ return 0;
-+ }
-+ return (strcmp(encr, epass) == 0);
- }
-
- /******************************************************************************/
diff --git a/net-misc/xrdp/xrdp-0.9.15.ebuild b/net-misc/xrdp/xrdp-0.9.15.ebuild
index 77ca33f..e05572c 100644
--- a/net-misc/xrdp/xrdp-0.9.15.ebuild
+++ b/net-misc/xrdp/xrdp-0.9.15.ebuild
@@ -1,6 +1,5 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-# $Id$
EAPI=7
@@ -39,21 +38,10 @@ RDEPEND="${RDEPEND}
src_prepare() {
default
- # don't let USE=debug adjust CFLAGS
- sed -i -e 's:-g -O0::' configure.ac || die
# disallow root login by default
sed -i -e '/^AllowRootLogin/s/true/false/' sesman/sesman.ini || die
- # reorder so that X11rdp comes last again since it's not supported
- sed -i -e '/^\[xrdp1\]$/,/^$/{wxrdp.ini.tmp
- ;d}' xrdp/xrdp.ini || die
- # move newline to the beginning
- sed -i -e 'x' xrdp.ini.tmp || die
- cat xrdp.ini.tmp >> xrdp/xrdp.ini || die
- rm -f xrdp.ini.tmp || die
eautoreconf
- # part of ./bootstrap
- ln -s ../config.c sesman/tools/config.c || die
}
src_configure() {
@@ -61,16 +49,15 @@ src_configure() {
&& ewarn "Both kerberos & pam auth enabled, kerberos will take precedence."
local myconf=(
- # warning: configure.ac is completed flawed
-
--localstatedir="${EPREFIX}"/var
# -- authentication backends --
# kerberos is inside !SESMAN_NOPAM conditional for no reason
$(use pam || use kerberos || echo --enable-nopam)
$(usex kerberos --enable-kerberos '')
+
# pam_userpass is not in Gentoo at the moment
- #--disable-pamuserpass
+ --disable-pamuserpass
# -- jpeg support --
$(usex jpeg --enable-jpeg '')
@@ -87,7 +74,7 @@ src_configure() {
# $(usex neutrinordp --enable-neutrinordp '')
# $(usex xrdpvr --enable-xrdpvr '')
- "$(systemd_with_unitdir)"
+ --with-systemdsystemunitdir="$(systemd_get_systemunitdir)"
)
econf "${myconf[@]}"
@@ -95,7 +82,8 @@ src_configure() {
src_install() {
default
- prune_libtool_files --all
+
+ find "${ED}" -name '*.la' -delete || die
# use our pam.d file since upstream's incompatible with Gentoo
use pam && newpamd "${FILESDIR}"/xrdp-sesman.pamd xrdp-sesman
@@ -103,15 +91,11 @@ src_install() {
exeinto /etc/xrdp
doexe "${FILESDIR}"/startwm.sh
- # Fedora stuff
- rm -r "${ED}"/etc/default || die
-
# own /etc/xrdp/rsakeys.ini
: > rsakeys.ini
insinto /etc/xrdp
doins rsakeys.ini
- # contributed by Jan Psota <jasiupsota@gmail.com>
newinitd "${FILESDIR}/${PN}-initd" ${PN}
}
@@ -141,5 +125,5 @@ pkg_postinst() {
elog "Various session types require different backend implementations:"
elog "- sesman-Xvnc requires net-misc/tigervnc[server,xorgmodule]"
- elog "- sesman-X11rdp requires net-misc/x11rdp"
+ elog "- sesman-Xorgrdp requires net-misc/xorgxrdp"
}