summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimothy Redaelli <drizzt@gentoo.org>2007-07-23 22:11:59 +0000
committerTimothy Redaelli <drizzt@gentoo.org>2007-07-23 22:11:59 +0000
commit3c1096093868eb61c9a87f6bdeafce10d2840284 (patch)
tree3a9ec9f6c322671d583ca896b3abb34711df0938
parentIn main tree (diff)
downloaddrizzt-3c1096093868eb61c9a87f6bdeafce10d2840284.tar.gz
drizzt-3c1096093868eb61c9a87f6bdeafce10d2840284.tar.bz2
drizzt-3c1096093868eb61c9a87f6bdeafce10d2840284.zip
Add filezilla as requested in mail.
Ebuild by Jason Smathers slightly edited by me. svn path=/; revision=135
-rw-r--r--net-ftp/filezilla/ChangeLog9
-rw-r--r--net-ftp/filezilla/Manifest13
-rw-r--r--net-ftp/filezilla/filezilla-3.0.0_beta11.ebuild53
3 files changed, 75 insertions, 0 deletions
diff --git a/net-ftp/filezilla/ChangeLog b/net-ftp/filezilla/ChangeLog
new file mode 100644
index 0000000..882a117
--- /dev/null
+++ b/net-ftp/filezilla/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for net-ftp/filezilla
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+ 23 Jul 2007; Timothy Redaelli <drizzt@gentoo.org>
+ +filezilla-3.0.0_beta11.ebuild:
+ Add filezilla as requested in mail.
+ Ebuild by Jason Smathers slightly edited by me.
+
diff --git a/net-ftp/filezilla/Manifest b/net-ftp/filezilla/Manifest
new file mode 100644
index 0000000..ca95d86
--- /dev/null
+++ b/net-ftp/filezilla/Manifest
@@ -0,0 +1,13 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+DIST FileZilla_3.0.0-beta11_src.tar.bz2 1464353 RMD160 32020512b4c48b2596bf595396f5e7641fe6eea0 SHA1 baaed64640057aa5aa7f2ef7b25f0a695aac4c13 SHA256 2d08ede96c2e36a692fd4e1d100de1eeec308b75394ca1cf83b5ce54959eee49
+EBUILD filezilla-3.0.0_beta11.ebuild 1108 RMD160 f6e29c688a9261ffb57315f080ddab3521c1cfe6 SHA1 1d342316bc404845c1744cb1bcfed0f337c0fd94 SHA256 6057716ac63e0b0c418a7d2b06bbea96ce08f61b834bbf5a1df03b407fde81ab
+MISC ChangeLog 293 RMD160 ca01c7156afc4f467344f09d00c13ea3d012d309 SHA1 b2b17940cd3c601d8a04703b2b851f686d097301 SHA256 01f864ee0ecff88964468e40b3731069508bd182514a5c1084d0f45caab2b9a5
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.4 (GNU/Linux)
+
+iD8DBQFGpSfIjJyKLBkBVroRAu+fAJ0XsbqTYY/IMSZ3FiUCyWZuiyEIBQCfT75+
+YdWxRUxEJIaDLDhAPlcRoaY=
+=hG5X
+-----END PGP SIGNATURE-----
diff --git a/net-ftp/filezilla/filezilla-3.0.0_beta11.ebuild b/net-ftp/filezilla/filezilla-3.0.0_beta11.ebuild
new file mode 100644
index 0000000..f0e2557
--- /dev/null
+++ b/net-ftp/filezilla/filezilla-3.0.0_beta11.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+WX_GTK_VER="2.8"
+
+inherit eutils multilib autotools wxwidgets
+
+MY_PV=${PV/_/-}
+MY_P="FileZilla_${MY_PV}"
+
+DESCRIPTION="FTP client with lots of useful features and an intuitive interface"
+HOMEPAGE="http://filezilla-project.org/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}_src.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=x11-libs/wxGTK-2.8.4
+ >=net-libs/gnutls-1.6.1
+ net-dns/libidn
+ >=sys-devel/libtool-1.4"
+DEPEND="${RDEPEND}
+ >=sys-devel/gettext-0.11"
+
+S="${WORKDIR}"/${PN}-${MY_PV}
+
+pkg_setup() {
+ if use unicode; then
+ need-wxwidgets "unicode"
+ else
+ need-wxwidgets "gtk2"
+ fi
+}
+
+src_compile() {
+ econf \
+ --with-wx-config="${WX_CONFIG}" \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ doicon src/interface/resources/${PN}.xpm || die "doicon failed"
+ make_desktop_entry ${PN} "FileZilla" ${PN}.xpm
+
+ dodoc AUTHORS ChangeLog NEWS
+}