summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-ftp/lftp/files')
-rw-r--r--net-ftp/lftp/files/lftp-4.0.2.91-lafile.patch21
-rw-r--r--net-ftp/lftp/files/lftp-4.0.3-autoconf-2.64.patch11
-rw-r--r--net-ftp/lftp/files/lftp-4.3.4-empty-local.patch27
3 files changed, 59 insertions, 0 deletions
diff --git a/net-ftp/lftp/files/lftp-4.0.2.91-lafile.patch b/net-ftp/lftp/files/lftp-4.0.2.91-lafile.patch
new file mode 100644
index 0000000..6180d92
--- /dev/null
+++ b/net-ftp/lftp/files/lftp-4.0.2.91-lafile.patch
@@ -0,0 +1,21 @@
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -18,7 +18,8 @@
+ example_module1_la_SOURCES = example-module1.cc
+ example_module1_la_LDFLAGS = -module -avoid-version -rpath $(pkgverlibdir)
+
+-TASK_MODULES = liblftp-pty.la liblftp-network.la proto-ftp.la proto-http.la proto-file.la proto-fish.la proto-sftp.la
++TASK_MODULES = liblftp-pty.la liblftp-network.la proto-ftp.la proto-http.la proto-file.la proto-fish.la proto-sftp.la liblftp-tasks.la liblftp-jobs.la
++
+ JOB_MODULES = cmd-mirror.la cmd-sleep.la cmd-torrent.la
+ if WITH_MODULES
+ pkgverlib_LTLIBRARIES = $(TASK_MODULES) $(JOB_MODULES)
+@@ -26,8 +27,6 @@
+ TASK_MODULES_STATIC = $(TASK_MODULES)
+ JOB_MODULES_STATIC = $(JOB_MODULES)
+ endif
+-lib_LTLIBRARIES = liblftp-tasks.la liblftp-jobs.la
+-
+ proto_ftp_la_SOURCES = ftpclass.cc ftpclass.h FtpListInfo.cc FtpListInfo.h\
+ FtpDirList.cc FtpDirList.h ftp-opie.c FileCopyFtp.cc FileCopyFtp.h
+ proto_http_la_SOURCES = Http.cc Http.h HttpDir.cc HttpDir.h HttpDirXML.cc
diff --git a/net-ftp/lftp/files/lftp-4.0.3-autoconf-2.64.patch b/net-ftp/lftp/files/lftp-4.0.3-autoconf-2.64.patch
new file mode 100644
index 0000000..def2b45
--- /dev/null
+++ b/net-ftp/lftp/files/lftp-4.0.3-autoconf-2.64.patch
@@ -0,0 +1,11 @@
+--- configure.ac-old 2009-10-16 18:44:26.000000000 +0200
++++ configure.ac 2009-11-21 15:09:58.000000000 +0100
+@@ -255,7 +255,7 @@
+ AC_ARG_WITH(gnutls, AS_HELP_STRING([--without-gnutls], [don't use GNUTLS library]),
+ [with_gnutls=$withval], [with_gnutls=yes])
+ AC_ARG_WITH(openssl,
+-AS_HELP_STRING([--with-openssl[[=/path]]], [use OpenSSL [at /path]])
++AS_HELP_STRING([--with-openssl@<:@=/path@:>@], [use OpenSSL @<:@at /path@:>@])
+ AS_HELP_STRING([--without-openssl], [don't use OpenSSL (default)]),
+ [with_openssl=$withval], [with_openssl=no])
+ case "$with_openssl" in
diff --git a/net-ftp/lftp/files/lftp-4.3.4-empty-local.patch b/net-ftp/lftp/files/lftp-4.3.4-empty-local.patch
new file mode 100644
index 0000000..928d459
--- /dev/null
+++ b/net-ftp/lftp/files/lftp-4.3.4-empty-local.patch
@@ -0,0 +1,27 @@
+--- a/src/CmdExec.cc
++++ b/src/CmdExec.cc
+@@ -197,6 +197,8 @@ restart:
+
+ const struct cmd_rec *c;
+ const char *cmd_name=args->getarg(0);
++ if(!cmd_name)
++ return;
+ int part=find_cmd(cmd_name,&c);
+ if(part<=0)
+ eprintf(_("Unknown command `%s'.\n"),cmd_name);
+@@ -1223,10 +1225,14 @@ Job *CmdExec::default_cmd()
+ }
+ Job *CmdExec::builtin_local()
+ {
++ if(args->count()<2) {
++ eprintf(_("Usage: %s cmd [args...]\n"),args->a0());
++ return 0;
++ }
+ saved_session=session.borrow();
+ session=FileAccess::New("file");
+ if(!session) {
+- eprintf("%s: cannot create local session\n",args->a0());
++ eprintf(_("%s: cannot create local session\n"),args->a0());
+ RevertToSavedSession();
+ return 0;
+ }