summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-drivers/xf86-video-fbturbo/xf86-video-fbturbo-0.4.0.ebuild')
-rw-r--r--x11-drivers/xf86-video-fbturbo/xf86-video-fbturbo-0.4.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/x11-drivers/xf86-video-fbturbo/xf86-video-fbturbo-0.4.0.ebuild b/x11-drivers/xf86-video-fbturbo/xf86-video-fbturbo-0.4.0.ebuild
new file mode 100644
index 0000000..c640f83
--- /dev/null
+++ b/x11-drivers/xf86-video-fbturbo/xf86-video-fbturbo-0.4.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+inherit xorg-2
+
+DESCRIPTION="Drop-in replacement for xf86-video-fbdev and xf86-video-mali providing a better performance on ARM"
+SRC_URI="https://github.com/ssvb/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="arm"
+IUSE=""
+
+RDEPEND="x11-base/xorg-server"
+DEPEND="${RDEPEND}
+ x11-proto/fontsproto
+ x11-proto/randrproto
+ x11-proto/renderproto
+ x11-proto/videoproto
+ x11-proto/xproto
+ x11-proto/xf86driproto
+"
+# FIXME: driproto shouldn't really be necessary on rpi
+
+src_prepare()
+{
+ xorg-2_src_prepare
+ # Was added upstream for fixing compilations somewhere, but doesn't seemed needed
+ # Not present with xorg-server[minimal]
+ sed -i -e 's:#include "dri2.h"::g' "${S}"/src/sunxi_x_g2d.c || die
+}