summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-auth/pam_google_authenticator/files/pam_google_authenticator-9999-as-needed.patch')
-rw-r--r--sys-auth/pam_google_authenticator/files/pam_google_authenticator-9999-as-needed.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/sys-auth/pam_google_authenticator/files/pam_google_authenticator-9999-as-needed.patch b/sys-auth/pam_google_authenticator/files/pam_google_authenticator-9999-as-needed.patch
new file mode 100644
index 0000000..02422cc
--- /dev/null
+++ b/sys-auth/pam_google_authenticator/files/pam_google_authenticator-9999-as-needed.patch
@@ -0,0 +1,16 @@
+diff -r 74cba81d489b libpam/Makefile
+--- a/libpam/Makefile Sun Sep 19 10:37:52 2010 -0700
++++ b/libpam/Makefile Tue Nov 23 10:50:15 2010 +0900
+@@ -35,10 +35,10 @@
+ $(RM) *.o *.so google-authenticator pam_google_authenticator_unittest
+
+ google-authenticator: google-authenticator.o base32.o hmac.o sha1.o
+- $(CC) -g $(LDFLAGS) -ldl -o $@ $+
++ $(CC) -g $(LDFLAGS) -rdynamic -o $@ $+ -ldl
+
+ pam_google_authenticator_unittest: pam_google_authenticator_unittest.o base32.o
+- $(CC) -g $(LDFLAGS) -rdynamic -ldl -lc -o $@ $+
++ $(CC) -g $(LDFLAGS) -rdynamic -o $@ $+ -ldl -lc
+
+ pam_google_authenticator.so: base32.o hmac.o sha1.o
+ pam_google_authenticator_testing.so: base32.o hmac.o sha1.o