summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/fvwm/fvwm-2.5.25.ebuild')
-rw-r--r--x11-wm/fvwm/fvwm-2.5.25.ebuild40
1 files changed, 17 insertions, 23 deletions
diff --git a/x11-wm/fvwm/fvwm-2.5.25.ebuild b/x11-wm/fvwm/fvwm-2.5.25.ebuild
index a41216e..9b68653 100644
--- a/x11-wm/fvwm/fvwm-2.5.25.ebuild
+++ b/x11-wm/fvwm/fvwm-2.5.25.ebuild
@@ -71,20 +71,7 @@ src_unpack() {
}
src_compile() {
- local myconf="--libexecdir=/usr/lib --with-imagepath=/usr/include/X11/bitmaps:/usr/include/X11/pixmaps:/usr/share/icons/fvwm --enable-package-subdirs"
-
- use readline && myconf="${myconf} --without-termcap-library"
-
- # FvwmGtk can be built as a gnome application, or a Gtk+ application.
- if ! use gtk; then
- myconf="${myconf} --disable-gtk --without-gnome"
- else
- if ! use imlib; then
- einfo "ATTN: You can safely ignore any imlib related configure errors."
- myconf="${myconf} --with-imlib-prefix=${T}"
- fi
- myconf="${myconf} --without-gnome"
- fi
+ local myconf="--libexecdir=/usr/lib --with-imagepath=/usr/include/X11/bitmaps:/usr/include/X11/pixmaps:/usr/share/icons/fvwm --enable-package-subdirs --without-gnome"
# Non-upstream email where bugs should be sent; used in fvwm-bug.
export FVWM_BUGADDR="desktop-wm@gentoo.org"
@@ -95,6 +82,17 @@ src_compile() {
# Signed chars are required.
use ppc && append-flags -fsigned-char
+ if use gtk; then
+ if ! use imlib; then
+ einfo "ATTN: You can safely ignore any imlib related configure errors."
+ myconf="${myconf} --with-imlib-prefix=${T}"
+ fi
+ else
+ myconf="${myconf} --disable-gtk"
+ fi
+
+ use readline && myconf="${myconf} --without-termcap-library"
+
econf ${myconf} \
$(use_enable bidi) \
$(use_enable debug debug-msgs) \
@@ -119,29 +117,25 @@ src_install() {
emake DESTDIR="${D}" install || die "emake install failed"
if use perl; then
-
local toolkits="gtk tcltk"
if ! use tk; then
- # Remove the Tk bindings (requires perl-tk)
rm -f "${D}/usr/share/fvwm/perllib/FVWM/Module/Tk.pm"
toolkits=${toolkits/tcltk/}
fi
+
if ! use gtk; then
- # Remove gtk bindings (requires gtk-perl/gtk2-perl)
rm -f "${D}/usr/share/fvwm/perllib/FVWM/Module/"Gtk{,2}.pm
toolkits=${toolkits/gtk/}
fi
- toolkits=${toolkits// /}
- if ! test "${toolkits}"; then
- # No perl toolkit bindings wanted, remove the unneeded files
- # and empty directories.
+
+ if ! test "${toolkits// /}"; then
rm -f "${D}/usr/share/fvwm/perllib/FVWM/Module/Toolkit.pm"
find "${D}/usr/share/fvwm/perllib" -depth -type d -exec rmdir {} \; 2>/dev/null
fi
else
- # Remove useless script if perllib isnt required.
- rm -rf "${D}/usr/bin/fvwm-perllib" "${D}/usr/share/man/man1/fvwm-perllib.1"
+ rm -rf "${D}/usr/bin/fvwm-perllib" \
+ "${D}/usr/share/man/man1/fvwm-perllib.1"
fi
# Utility for testing FVWM behaviour by creating a simple window with