summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Heim <phreak@gentoo.org>2007-08-23 19:08:24 +0000
committerChristian Heim <phreak@gentoo.org>2007-08-23 19:08:24 +0000
commit77410c4a0c1b314056549ed41fadb8cad45a0f8b (patch)
tree9edd58a6105a6bcbbef3cea8364049ac5c822af2
parentFixing the manifest. (diff)
downloadphreak-77410c4a0c1b314056549ed41fadb8cad45a0f8b.tar.gz
phreak-77410c4a0c1b314056549ed41fadb8cad45a0f8b.tar.bz2
phreak-77410c4a0c1b314056549ed41fadb8cad45a0f8b.zip
Add app-arch/apt and app-arch/reprepro to my repository.
svn path=/; revision=361
-rw-r--r--private/app-arch/apt/Manifest2
-rw-r--r--private/app-arch/apt/apt-0.7.6.ebuild45
-rw-r--r--private/app-arch/reprepro/Manifest4
-rw-r--r--private/app-arch/reprepro/files/reprepro-2.2.4-db4.5.patch51
-rw-r--r--private/app-arch/reprepro/files/reprepro-2.2.4-gpgme.patch22
-rw-r--r--private/app-arch/reprepro/reprepro-2.2.4-r1.ebuild45
6 files changed, 169 insertions, 0 deletions
diff --git a/private/app-arch/apt/Manifest b/private/app-arch/apt/Manifest
new file mode 100644
index 0000000..0d06112
--- /dev/null
+++ b/private/app-arch/apt/Manifest
@@ -0,0 +1,2 @@
+DIST apt_0.7.6.tar.gz 1821767 RMD160 527639ac0b3173c95994af218c6fdd1bd1066a49 SHA1 b428e1fe3c41688e2396ff3bd6e36f7a532d7bd1 SHA256 4a4eb39ea162df9c795b472326e9df676dbf249dc34436517b67354f32a8d23f
+EBUILD apt-0.7.6.ebuild 1177 RMD160 93bff2ebc107143341716574bd13043f6d4ad6d6 SHA1 6d9f6892ea6a103e63e880ff34a6f65ef85d2604 SHA256 904a34d50c5e2ee3f349c153109f2dfb65d27b28306d62186cdb8ff9d628c3c1
diff --git a/private/app-arch/apt/apt-0.7.6.ebuild b/private/app-arch/apt/apt-0.7.6.ebuild
new file mode 100644
index 0000000..bb2223c
--- /dev/null
+++ b/private/app-arch/apt/apt-0.7.6.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils autotools multilib
+
+DESCRIPTION=""
+HOMEPAGE=""
+SRC_URI="mirror://debian/pool/main/a/apt/apt_${PV}.tar.gz"
+
+LICENSE="GPL-v2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="doc xml"
+
+RDEPEND="app-arch/dpkg"
+DEPEND="doc? ( app-doc/doxygen )
+ xml? ( app-text/xmlto )
+ ${RDEPEND}"
+
+src_install() {
+ # Install only necessary things, as we don't need another package manager
+ dobin "${S}"/bin/apt-*
+
+ insinto /usr/$(get_libdir)
+ doins "${S}"/bin/libapt-inst*.1.1.0 "${S}"/bin/libapt-pkg*.4.4.0
+ dosym /usr/$(get_libdir)/libapt-inst-libc6.6-6.so.1.1.0 \
+ /usr/$(get_libdir)/libapt-inst-libc6.6-6.so.1.1
+
+ dosym /usr/$(get_libdir)/libapt-inst-libc6.6-6.so.1.1.0 \
+ /usr/$(get_libdir)/libapt-inst.so
+
+ dosym /usr/$(get_libdir)/libapt-pkg-libc6.6-6.so.4.4.0 \
+ /usr/$(get_libdir)/libapt-pkg-libc6.6-6.so.4.4
+ dosym /usr/$(get_libdir)/libapt-pkg-libc6.6-6.so.4.4.0 \
+ /usr/$(get_libdir)/libapt-pkg.so
+
+ insinto /usr/$(get_libdir)/apt/methods
+ doins "${S}"/bin/methods/*
+
+ dodoc AUTHORS BUGS debian/changelog
+ docinto examples
+ dodoc doc/examples/*
+ doman doc/*.?
+}
diff --git a/private/app-arch/reprepro/Manifest b/private/app-arch/reprepro/Manifest
new file mode 100644
index 0000000..b75a6d6
--- /dev/null
+++ b/private/app-arch/reprepro/Manifest
@@ -0,0 +1,4 @@
+AUX reprepro-2.2.4-db4.5.patch 1908 RMD160 75df764e5fc0d8c35db33147dca26adcf663ae98 SHA1 50894d8766c81e872c22953aabb5166f8b3e7153 SHA256 2ad14099f977273d231ff74d169f1195f8fb8e7eb87f3a6e159f542303869dcf
+AUX reprepro-2.2.4-gpgme.patch 795 RMD160 f9338227b3def706a7e646ba519c11b06360189c SHA1 02a45191e27a536693ae84c79410f0d5458e5db5 SHA256 bff79373963861f54b6e07db09461b3d01af3499dbf3a78590f22e6f165397c6
+DIST reprepro_2.2.4.orig.tar.gz 363292 RMD160 901f5c60fb26339b20446053d18d118b2daf4e19 SHA1 32fdd7acc1196a769d6e0a8f55e9ba110c99d34c SHA256 5bcc1b21b622ee24962b17827cfbc36db17bbcb5c78347a07ab5a85b22c2d0eb
+EBUILD reprepro-2.2.4-r1.ebuild 841 RMD160 a949cf17b72ab84f83b2c3641938f366c0a95344 SHA1 f02cbd1d7854ef80b488f6a5c6f6664f5c6ecad8 SHA256 6d829d0c0e4ad39e51192d1a69c409082128f43adfd42c0c8db2a3ff9555ed54
diff --git a/private/app-arch/reprepro/files/reprepro-2.2.4-db4.5.patch b/private/app-arch/reprepro/files/reprepro-2.2.4-db4.5.patch
new file mode 100644
index 0000000..1b8a423
--- /dev/null
+++ b/private/app-arch/reprepro/files/reprepro-2.2.4-db4.5.patch
@@ -0,0 +1,51 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -31,6 +31,9 @@ AC_ARG_WITH(libdb,
+ 4.4)
+ DB_WANT_VERSION=4.4
+ ;;
++ 4.5)
++ DB_WANT_VERSION=4.5
++ ;;
+ ?|?.?)
+ AC_MSG_ERROR([Unknown --with-libdb argument $withval])
+ ;;
+@@ -71,6 +74,12 @@ elif test "x$DB_VERSION_MAJOR" = "x4" -a
+ elif test "$DB_WANT_VERSION" != "4.4" ; then
+ AC_MSG_ERROR([Found libdb major version $DB_VERSION_MAJOR.$DB_VERSION_MINOR, need $DB_WANT_VERSION])
+ fi
++elif test "x$DB_VERSION_MAJOR" = "x4" -a "x$DB_VERSION_MINOR" = "x5" ; then
++ if test "$DB_WANT_VERSION" = "any" ; then
++ DB_WANT_VERSION=4.5
++ elif test "$DB_WANT_VERSION" != "4.5" ; then
++ AC_MSG_ERROR([Found libdb major version $DB_VERSION_MAJOR.$DB_VERSION_MINOR, need $DB_WANT_VERSION])
++ fi
+ else
+ AC_MSG_ERROR([Unsupported libdb major $DB_VERSION_MAJOR minor $DB_VERSION_MINOR
+ Only 4.3 (stronly recommended) or 3.2 or 4.4 are supported])
+@@ -78,6 +87,12 @@ fi
+
+ # now we have a header with the expected version, check for the library:
+ case "$DB_WANT_VERSION" in
++4.5)
++ AC_CHECK_LIB(db-4.5,db_create,[dnl
++ AC_DEFINE_UNQUOTED(AS_TR_CPP(LIBDB_VERSION),45)
++ DBLIBS="-ldb-4.5 $DBLIBS"
++ ],[AC_MSG_ERROR(["no libdb-4.5 found"])],[$DBLIBS])
++;;
+ 4.4)
+ AC_CHECK_LIB(db-4.4,db_create,[dnl
+ AC_DEFINE_UNQUOTED(AS_TR_CPP(LIBDB_VERSION),44)
+--- a/globals.h
++++ b/globals.h
+@@ -40,7 +40,9 @@ enum config_option_owner { CONFIG_OWNER
+ CONFIG_OWNER_FILE,
+ CONFIG_OWNER_ENVIRONMENT,
+ CONFIG_OWNER_CMDLINE};
+-#if LIBDB_VERSION == 44
++#if LIBDB_VERSION == 45
++#define DB_OPEN(database,filename,name,type,flags) database->open(database,NULL,filename,name,type,flags,0664)
++#elif LIBDB_VERSION == 44
+ #define DB_OPEN(database,filename,name,type,flags) database->open(database,NULL,filename,name,type,flags,0664)
+ #elif LIBDB_VERSION == 43
+ #define DB_OPEN(database,filename,name,type,flags) database->open(database,NULL,filename,name,type,flags,0664)
diff --git a/private/app-arch/reprepro/files/reprepro-2.2.4-gpgme.patch b/private/app-arch/reprepro/files/reprepro-2.2.4-gpgme.patch
new file mode 100644
index 0000000..f0dd393
--- /dev/null
+++ b/private/app-arch/reprepro/files/reprepro-2.2.4-gpgme.patch
@@ -0,0 +1,22 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -120,7 +120,7 @@ AC_SUBST([DBCPPFLAGS])
+ AC_CHECK_LIB(z,gzopen,,[AC_MSG_ERROR(["no zlib found"])],)
+ AC_CHECK_LIB(gpg-error,gpg_strsource,,[AC_MSG_ERROR(["no libgpg-error found"])],)
+ AC_CHECK_LIB(gpgme,gpgme_get_protocol_name,,[AC_MSG_ERROR(["no libgpgme found (need at least 0.4.1)"])],)
+-AC_CHECK_HEADER(gpgme.h,,[AC_MSG_ERROR(["no gpgme.h found"])])
++AC_CHECK_HEADER(gpgme/gpgme.h,,[AC_MSG_ERROR(["no gpgme.h found"])])
+
+ AC_ARG_WITH(libbz2,
+ [ --with-libbz2=path|yes|no Give path to prefix libbz2 was installed with],[dnl
+--- a/signature.c
++++ b/signature.c
+@@ -25,7 +25,7 @@
+ #include <string.h>
+ #include <malloc.h>
+ #include <fcntl.h>
+-#include <gpgme.h>
++#include <gpgme/gpgme.h>
+ #include "error.h"
+ #include "ignore.h"
+ #include "mprintf.h"
diff --git a/private/app-arch/reprepro/reprepro-2.2.4-r1.ebuild b/private/app-arch/reprepro/reprepro-2.2.4-r1.ebuild
new file mode 100644
index 0000000..422559c
--- /dev/null
+++ b/private/app-arch/reprepro/reprepro-2.2.4-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils autotools
+
+DESCRIPTION=""
+HOMEPAGE=""
+SRC_URI="mirror://debian/pool/main/r/reprepro/reprepro_${PV}.orig.tar.gz"
+
+LICENSE="GPL-v2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="bzip2"
+
+DEPEND="app-crypt/gnupg
+ ~sys-libs/db-4.5
+ app-arch/libarchive
+ bzip2? ( app-arch/bzip2 )
+ app-crypt/gpgme"
+RDEPEND="${DEPEND}
+ app-arch/apt"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${P}-db4.5.patch
+ epatch "${FILESDIR}"/${P}-gpgme.patch
+ eautoreconf
+}
+
+src_compile() {
+ cd "${S}"
+
+ econf \
+ --with-libdb=4.5 \
+ --with-gpgme=/usr/include/gpgme || die "econf failed!"
+ emake || die "emake failed!"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed!"
+ dodoc ChangeLog TODO README NEWS
+}