summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/nagcon/files/nagcon-0.0.30.patch')
-rw-r--r--net-analyzer/nagcon/files/nagcon-0.0.30.patch56
1 files changed, 56 insertions, 0 deletions
diff --git a/net-analyzer/nagcon/files/nagcon-0.0.30.patch b/net-analyzer/nagcon/files/nagcon-0.0.30.patch
new file mode 100644
index 0000000..0e70b93
--- /dev/null
+++ b/net-analyzer/nagcon/files/nagcon-0.0.30.patch
@@ -0,0 +1,56 @@
+diff -urN nagcon-0.0.30.orig/Makefile nagcon-0.0.30/Makefile
+--- nagcon-0.0.30.orig/Makefile 2008-07-31 13:57:31.000000000 +0200
++++ nagcon-0.0.30/Makefile 2008-08-01 19:17:39.018319961 +0200
+@@ -1,7 +1,7 @@
+ VERSION=0.0.30
+
+-DEBUG= -g # -D_DEBUG -g -fprofile-arcs -ftest-coverage # -pg -g
+-CXXFLAGS+=-Wall -g -O2 -DVERSION=\"${VERSION}\" $(DEBUG)
++DEBUG= # -D_DEBUG -g -fprofile-arcs -ftest-coverage # -pg -g
++CXXFLAGS+=-Wall -g -DVERSION=\"${VERSION}\" $(DEBUG)
+ CFLAGS+=${CXXFLAGS}
+ LDFLAGS+=$(DEBUG) -lncurses -lstdc++
+
+diff -urN nagcon-0.0.30.orig/nc.cpp nagcon-0.0.30/nc.cpp
+--- nagcon-0.0.30.orig/nc.cpp 2008-07-31 13:57:31.000000000 +0200
++++ nagcon-0.0.30/nc.cpp 2008-08-01 19:20:10.246175059 +0200
+@@ -177,8 +177,8 @@
+ version();
+
+ printf("-f file what file to monitor (usuallly:\n");
+- printf("-F host:port connect to a host for retrieving the status.log information\n");
+- printf(" /usr/local/nagios/var/status.log, look for status_file in\n");
++ printf("-F host:port connect to a host for retrieving the status information\n");
++ printf(" /var/nagios/status.dat, look for status_file in\n");
+ printf(" the nagios.cfg file\n");
+ printf("-i x check interval (in seconds)\n");
+ printf("-a list also the services for hosts that are down\n");
+@@ -187,8 +187,8 @@
+ printf("-g turn off grouping by status\n");
+ printf("-s change sort order\n");
+ printf("-e/-o suppress services with ok status\n");
+- printf("-x status.log-file is in Nagios 1.0 format\n");
+- printf("-X status.log-file is in Nagios 2.0 format\n");
++ printf("-x status file is in Nagios 1.0 format\n");
++ printf("-X status file is in Nagios 2.0 format\n");
+ printf("-1 x set width of hostname column\n");
+ printf("-2 x set width of service description column\n");
+ printf("-h this help\n");
+@@ -210,7 +210,7 @@
+ WINDOW *win;
+ int sw;
+
+- char *status_log = "/usr/local/nagios/var/status.log";
++ char *status_log = "/var/nagios/status.dat";
+ int interval = 5;
+ char list_all_problems = 0;
+ char always_notify = 0;
+@@ -297,7 +297,7 @@
+ }
+
+ if (file_mode == 0 && stat(status_log, &statstruct) == -1)
+- error_exit("error accessing nagios status.log file! (%s)", status_log);
++ error_exit("error accessing nagios status file! (%s)", status_log);
+
+ init_curses();
+ signal(SIGWINCH, do_resize);