aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPhilipp A <flying-sheep@web.de>2019-03-27 22:34:19 +0100
committerCheryl Sabella <cheryl.sabella@gmail.com>2019-03-27 17:34:19 -0400
commitd5a5a33f12b60129d57f9b423b77d2fcba506834 (patch)
tree467f333ea40737d6598e845cdc346d77196c2a24 /Lib/distutils/command/check.py
parentAdd missing docstrings for TarInfo objects (#12555) (diff)
downloadcpython-d5a5a33f12b60129d57f9b423b77d2fcba506834.tar.gz
cpython-d5a5a33f12b60129d57f9b423b77d2fcba506834.tar.bz2
cpython-d5a5a33f12b60129d57f9b423b77d2fcba506834.zip
bpo-31292: Fixed distutils check --restructuredtext for include directives (GH-10605)
Diffstat (limited to 'Lib/distutils/command/check.py')
-rw-r--r--Lib/distutils/command/check.py3
1 files changed, 2 insertions, 1 deletions
diff --git a/Lib/distutils/command/check.py b/Lib/distutils/command/check.py
index 7ebe707cff4..04c2f9642d7 100644
--- a/Lib/distutils/command/check.py
+++ b/Lib/distutils/command/check.py
@@ -120,7 +120,8 @@ class check(Command):
def _check_rst_data(self, data):
"""Returns warnings when the provided data doesn't compile."""
- source_path = StringIO()
+ # the include and csv_table directives need this to be a path
+ source_path = self.distribution.script_name or 'setup.py'
parser = Parser()
settings = frontend.OptionParser(components=(Parser,)).get_default_values()
settings.tab_width = 4