aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Felt <aixtools@users.noreply.github.com>2019-12-15 15:17:53 +0100
committerNick Coghlan <ncoghlan@gmail.com>2019-12-16 00:17:53 +1000
commit39afa2d3147e4b05a1161cc90dbf09b95072c2bb (patch)
tree4e55f8d4697cc79658b89c0ccfa1d43dfb01ecb7 /configure.ac
parentbpo-39035: travis: Don't use beta group (GH-17602) (diff)
downloadcpython-39afa2d3147e4b05a1161cc90dbf09b95072c2bb.tar.gz
cpython-39afa2d3147e4b05a1161cc90dbf09b95072c2bb.tar.bz2
cpython-39afa2d3147e4b05a1161cc90dbf09b95072c2bb.zip
bpo-38021: Modify AIX platform_tag so it covers PEP 425 needs (GH-17303)
Provides a richer platform tag for AIX that we expect to be sufficient for PEP 425 binary distribution identification. Any backports to earlier Python versions will be handled via setuptools. Patch by Michael Felt.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 11 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 0b28dda44cd..57dca35723c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2858,7 +2858,17 @@ case "$ac_sys_system" in
AC_MSG_RESULT(yes)
],[
AC_MSG_RESULT(no)
- ]);;
+ ])
+dnl The AIX_BUILDDATE is obtained from the kernel fileset - bos.mp64
+# BUILD_GNU_TYPE + AIX_BUILDDATE are used to construct the platform_tag
+# of the AIX system used to build/package Python executable. This tag serves
+# as a baseline for bdist module packages
+ AC_MSG_CHECKING(for the system builddate)
+ AIX_BUILDDATE=$(lslpp -Lcq bos.mp64 | awk -F: '{ print $NF }')
+ AC_DEFINE_UNQUOTED([AIX_BUILDDATE], [$AIX_BUILDDATE],
+ [BUILD_GNU_TYPE + AIX_BUILDDATE are used to construct the PEP425 tag of the build system.])
+ AC_MSG_RESULT($AIX_BUILDDATE)
+ ;;
*) ;;
esac