aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVictor Stinner <vstinner@python.org>2020-01-22 22:48:16 +0100
committerGitHub <noreply@github.com>2020-01-22 22:48:16 +0100
commitb477d19a6b7751b0c933b239dae4fc96dbcde9c4 (patch)
treea9de7a34e4e80d20192f5db44893e247136f0c51 /configure.ac
parentbpo-39406: os.putenv() avoids putenv_dict on Windows (GH-18126) (diff)
downloadcpython-b477d19a6b7751b0c933b239dae4fc96dbcde9c4.tar.gz
cpython-b477d19a6b7751b0c933b239dae4fc96dbcde9c4.tar.bz2
cpython-b477d19a6b7751b0c933b239dae4fc96dbcde9c4.zip
bpo-39406: Implement os.putenv() with setenv() if available (GH-18128)
If setenv() C function is available, os.putenv() is now implemented with setenv() instead of putenv(), so Python doesn't have to handle the environment variable memory.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index bcef99c4962..36c165b2f2e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3600,7 +3600,7 @@ AC_CHECK_FUNCS(alarm accept4 setitimer getitimer bind_textdomain_codeset chown \
posix_fallocate posix_fadvise posix_spawn posix_spawnp pread preadv preadv2 \
pthread_condattr_setclock pthread_init pthread_kill putenv pwrite pwritev pwritev2 \
readlink readlinkat readv realpath renameat \
- sem_open sem_timedwait sem_getvalue sem_unlink sendfile setegid seteuid \
+ sem_open sem_timedwait sem_getvalue sem_unlink sendfile setegid setenv seteuid \
setgid sethostname \
setlocale setregid setreuid setresuid setresgid setsid setpgid setpgrp setpriority setuid setvbuf \
sched_get_priority_max sched_setaffinity sched_setscheduler sched_setparam \