diff options
author | Siddhesh Poyarekar <siddhesh@sourceware.org> | 2017-06-15 15:12:54 +0530 |
---|---|---|
committer | Siddhesh Poyarekar <siddhesh@sourceware.org> | 2017-06-15 15:12:54 +0530 |
commit | 2c0b90ab443abc967cbf75add4f7fde84978cb95 (patch) | |
tree | 600ed279223cf8a1e3a28bf623309fe9a51a6f8e | |
parent | nptl: Invert the mmap/mprotect logic on allocated stacks (BZ#18988) (diff) | |
download | glibc-2c0b90ab443abc967cbf75add4f7fde84978cb95.tar.gz glibc-2c0b90ab443abc967cbf75add4f7fde84978cb95.tar.bz2 glibc-2c0b90ab443abc967cbf75add4f7fde84978cb95.zip |
Enable tunables by default
All of the major architectures are adopting tunables as a way to add
tuning to the library, from hwcap_mask for aarch64 to HLE for s390 and
ifunc and cache geometry for x86. Given this adoption and the fact
that we don't want additional tuning knobs to be added outside of
tunables, it makes sense to enable tunables by default using this
trivial patch.
Smoke tested on x86 to ensure that tunables code was built without
specifying it as a configure flag. I have kept it as --enabled and
not changed it to --disable since we want to still keep the option of
different kinds of front-ends for tunables.
* configure.ac(--enable-tunables): Enable by default.
* configure: Regenerate.
* NEWS: Mention change.
* manual/install.texi (enable-tunables): Adjust documentation.
* INSTALL: Regenerate.
-rw-r--r-- | ChangeLog | 8 | ||||
-rw-r--r-- | INSTALL | 18 | ||||
-rw-r--r-- | NEWS | 3 | ||||
-rwxr-xr-x | configure | 2 | ||||
-rw-r--r-- | configure.ac | 2 | ||||
-rw-r--r-- | manual/install.texi | 13 |
6 files changed, 27 insertions, 19 deletions
@@ -1,3 +1,11 @@ +2017-06-15 Siddhesh Poyarekar <siddhesh@sourceware.org> + + * configure.ac(--enable-tunables): Enable by default. + * configure: Regenerate. + * NEWS: Mention change. + * manual/install.texi (enable-tunables): Adjust documentation. + * INSTALL: Regenerate. + 2017-06-14 Adhemerval Zanella <adhemerval.zanella@linaro.org> [BZ #18988] @@ -177,18 +177,16 @@ will be used, and CFLAGS sets optimization options for the compiler. '--enable-tunables' Tunables support allows additional library parameters to be - customized at runtime. This is an experimental feature and affects - startup time and is thus disabled by default. This option can take - the following values: - - 'no' - This is the default if the option is not passed to configure. - This disables tunables. + customized at runtime. This feature is enabled by default. This + option can take the following values: 'yes' - This is the default if the option is passed to configure. - This enables tunables and selects the default frontend - (currently 'valstring'). + This is the default if no option is passed to configure. This + enables tunables and selects the default frontend (currently + 'valstring'). + + 'no' + This option disables tunables. 'valstring' This enables tunables and selects the 'valstring' frontend for @@ -95,6 +95,9 @@ Version 2.26 as atomic variables to try to implement Dekker's mutual exclusion algorithm). +* The tunables feature is now enabled by default. This allows users to tweak + behavior of the GNU C Library using the GLIBC_TUNABLES environment variable. + Security related changes: * The DNS stub resolver limits the advertised UDP buffer size to 1200 bytes, @@ -3725,7 +3725,7 @@ fi if test "${enable_tunables+set}" = set; then : enableval=$enable_tunables; have_tunables=$enableval else - have_tunables=no + have_tunables=yes fi diff --git a/configure.ac b/configure.ac index 3f486d6df4..4c0a18edd9 100644 --- a/configure.ac +++ b/configure.ac @@ -436,7 +436,7 @@ AC_ARG_ENABLE([tunables], [AS_HELP_STRING([--enable-tunables], [Enable tunables support. Known values are 'yes', 'no' and 'valstring'])], [have_tunables=$enableval], - [have_tunables=no]) + [have_tunables=yes]) AC_SUBST(have_tunables) if test "$have_tunables" = yes; then AC_DEFINE(HAVE_TUNABLES) diff --git a/manual/install.texi b/manual/install.texi index d39d2daacd..cbc912817a 100644 --- a/manual/install.texi +++ b/manual/install.texi @@ -208,18 +208,17 @@ Use this option to disable the vector math library. @item --enable-tunables Tunables support allows additional library parameters to be customized at -runtime. This is an experimental feature and affects startup time and is thus -disabled by default. This option can take the following values: +runtime. This feature is enabled by default. This option can take the +following values: @table @code -@item no -This is the default if the option is not passed to configure. This disables -tunables. - @item yes -This is the default if the option is passed to configure. This enables tunables +This is the default if no option is passed to configure. This enables tunables and selects the default frontend (currently @samp{valstring}). +@item no +This option disables tunables. + @item valstring This enables tunables and selects the @samp{valstring} frontend for tunables. This frontend allows users to specify tunables as a colon-separated list in a |