aboutsummaryrefslogtreecommitdiff
path: root/nptl
diff options
context:
space:
mode:
authorSamuel Thibault <samuel.thibault@ens-lyon.org>2020-02-09 19:50:21 +0000
committerSamuel Thibault <samuel.thibault@ens-lyon.org>2020-02-09 19:50:21 +0000
commit28c30a6232aa9a54783c146590498a061fc0112a (patch)
treebe91a57e6b2895cec3d761d10469483c173fcb6c /nptl
parenthtl: support cancellation during pthread_once (diff)
downloadglibc-28c30a6232aa9a54783c146590498a061fc0112a.tar.gz
glibc-28c30a6232aa9a54783c146590498a061fc0112a.tar.bz2
glibc-28c30a6232aa9a54783c146590498a061fc0112a.zip
pthread: Move most once tests from nptl to sysdeps/pthread
So they can be checked with htl too.
Diffstat (limited to 'nptl')
-rw-r--r--nptl/Makefile7
-rw-r--r--nptl/tst-once1.c50
-rw-r--r--nptl/tst-once2.c102
-rw-r--r--nptl/tst-once3.c165
-rw-r--r--nptl/tst-once4.c200
-rw-r--r--nptl/tst-oncex3.c1
-rw-r--r--nptl/tst-oncex4.c1
7 files changed, 2 insertions, 524 deletions
diff --git a/nptl/Makefile b/nptl/Makefile
index 8fadd1d025..bf21413c26 100644
--- a/nptl/Makefile
+++ b/nptl/Makefile
@@ -248,7 +248,7 @@ tests = tst-attr2 tst-attr3 tst-default-attr \
tst-rwlock4 tst-rwlock5 tst-rwlock6 tst-rwlock7 tst-rwlock8 \
tst-rwlock9 tst-rwlock10 tst-rwlock11 tst-rwlock12 tst-rwlock13 \
tst-rwlock14 tst-rwlock15 tst-rwlock16 tst-rwlock17 tst-rwlock18 \
- tst-once1 tst-once2 tst-once3 tst-once4 tst-once5 \
+ tst-once5 \
tst-key1 tst-key2 tst-key3 tst-key4 \
tst-sem1 tst-sem2 tst-sem3 tst-sem4 tst-sem5 tst-sem6 tst-sem7 \
tst-sem8 tst-sem9 tst-sem10 tst-sem14 \
@@ -375,8 +375,7 @@ tests += tst-cancelx2 tst-cancelx3 tst-cancelx4 tst-cancelx5 \
tst-cancelx6 tst-cancelx7 tst-cancelx8 tst-cancelx9 tst-cancelx10 \
tst-cancelx11 tst-cancelx12 tst-cancelx13 tst-cancelx14 tst-cancelx15 \
tst-cancelx16 tst-cancelx17 tst-cancelx18 tst-cancelx20 tst-cancelx21 \
- tst-cleanupx0 tst-cleanupx1 tst-cleanupx2 tst-cleanupx3 tst-cleanupx4 \
- tst-oncex3 tst-oncex4
+ tst-cleanupx0 tst-cleanupx1 tst-cleanupx2 tst-cleanupx3 tst-cleanupx4
ifeq ($(build-shared),yes)
tests += tst-atfork2 tst-tls4 tst-_res1 tst-fini1 tst-compat-forwarder \
tst-audit-threads
@@ -516,8 +515,6 @@ CFLAGS-tst-cleanupx2.c += -fexceptions
CFLAGS-tst-cleanupx3.c += -fexceptions
CFLAGS-tst-cleanupx4.c += -fexceptions
CFLAGS-tst-cleanupx4aux.c += -fexceptions
-CFLAGS-tst-oncex3.c += -fexceptions
-CFLAGS-tst-oncex4.c += -fexceptions
CFLAGS-tst-align.c += $(stack-align-test-flags)
CFLAGS-tst-align3.c += $(stack-align-test-flags)
CFLAGS-tst-initializers1.c += -W -Wall -Werror
diff --git a/nptl/tst-once1.c b/nptl/tst-once1.c
deleted file mode 100644
index 16a5d8f18d..0000000000
--- a/nptl/tst-once1.c
+++ /dev/null
@@ -1,50 +0,0 @@
-/* Copyright (C) 2002-2020 Free Software Foundation, Inc.
- This file is part of the GNU C Library.
- Contributed by Ulrich Drepper <drepper@redhat.com>, 2002.
-
- The GNU C Library is free software; you can redistribute it and/or
- modify it under the terms of the GNU Lesser General Public
- License as published by the Free Software Foundation; either
- version 2.1 of the License, or (at your option) any later version.
-
- The GNU C Library is distributed in the hope that it will be useful,
- but WITHOUT ANY WARRANTY; without even the implied warranty of
- MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
- Lesser General Public License for more details.
-
- You should have received a copy of the GNU Lesser General Public
- License along with the GNU C Library; if not, see
- <https://www.gnu.org/licenses/>. */
-
-#include <pthread.h>
-#include <stdio.h>
-
-
-static pthread_once_t once = PTHREAD_ONCE_INIT;
-
-static int global;
-
-static void
-once_handler (void)
-{
- ++global;
-}
-
-
-static int
-do_test (void)
-{
- pthread_once (&once, once_handler);
- pthread_once (&once, once_handler);
-
- if (global != 1)
- {
- printf ("global = %d, expected 1\n", global);
- return 1;
- }
-
- return 0;
-}
-
-#define TEST_FUNCTION do_test ()
-#include "../test-skeleton.c"
diff --git a/nptl/tst-once2.c b/nptl/tst-once2.c
deleted file mode 100644
index 15c6efa5d4..0000000000
--- a/nptl/tst-once2.c
+++ /dev/null
@@ -1,102 +0,0 @@
-/* Copyright (C) 2002-2020 Free Software Foundation, Inc.
- This file is part of the GNU C Library.
- Contributed by Ulrich Drepper <drepper@redhat.com>, 2002.
-
- The GNU C Library is free software; you can redistribute it and/or
- modify it under the terms of the GNU Lesser General Public
- License as published by the Free Software Foundation; either
- version 2.1 of the License, or (at your option) any later version.
-
- The GNU C Library is distributed in the hope that it will be useful,
- but WITHOUT ANY WARRANTY; without even the implied warranty of
- MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
- Lesser General Public License for more details.
-
- You should have received a copy of the GNU Lesser General Public
- License along with the GNU C Library; if not, see
- <https://www.gnu.org/licenses/>. */
-
-#include <pthread.h>
-#include <stdio.h>
-#include <stdlib.h>
-#include <time.h>
-
-
-#define N 100
-
-static pthread_once_t once = PTHREAD_ONCE_INIT;
-
-static int global;
-
-static void
-once_handler (void)
-{
- struct timespec ts;
-
- ++global;
-
- ts.tv_sec = 2;
- ts.tv_nsec = 0;
- nanosleep (&ts, NULL);
-}
-
-
-static void *
-tf (void *arg)
-{
- pthread_once (&once, once_handler);
-
- if (global != 1)
- {
- printf ("thread %ld: global == %d\n", (long int) arg, global);
- exit (1);
- }
-
- return NULL;
-}
-
-
-static int
-do_test (void)
-{
- pthread_attr_t at;
- pthread_t th[N];
- int cnt;
-
- if (pthread_attr_init (&at) != 0)
- {
- puts ("attr_init failed");
- return 1;
- }
-
- if (pthread_attr_setstacksize (&at, 1 * 1024 * 1024) != 0)
- {
- puts ("attr_setstacksize failed");
- return 1;
- }
-
- for (cnt = 0; cnt < N; ++cnt)
- if (pthread_create (&th[cnt], &at, tf, (void *) (long int) cnt) != 0)
- {
- printf ("creation of thread %d failed\n", cnt);
- return 1;
- }
-
- if (pthread_attr_destroy (&at) != 0)
- {
- puts ("attr_destroy failed");
- return 1;
- }
-
- for (cnt = 0; cnt < N; ++cnt)
- if (pthread_join (th[cnt], NULL) != 0)
- {
- printf ("join of thread %d failed\n", cnt);
- return 1;
- }
-
- return 0;
-}
-
-#define TEST_FUNCTION do_test ()
-#include "../test-skeleton.c"
diff --git a/nptl/tst-once3.c b/nptl/tst-once3.c
deleted file mode 100644
index 4e339de6d6..0000000000
--- a/nptl/tst-once3.c
+++ /dev/null
@@ -1,165 +0,0 @@
-/* Copyright (C) 2002-2020 Free Software Foundation, Inc.
- This file is part of the GNU C Library.
- Contributed by Ulrich Drepper <drepper@redhat.com>, 2002.
-
- The GNU C Library is free software; you can redistribute it and/or
- modify it under the terms of the GNU Lesser General Public
- License as published by the Free Software Foundation; either
- version 2.1 of the License, or (at your option) any later version.
-
- The GNU C Library is distributed in the hope that it will be useful,
- but WITHOUT ANY WARRANTY; without even the implied warranty of
- MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
- Lesser General Public License for more details.
-
- You should have received a copy of the GNU Lesser General Public
- License along with the GNU C Library; if not, see
- <https://www.gnu.org/licenses/>. */
-
-#include <pthread.h>
-#include <stdio.h>
-#include <stdlib.h>
-#include <time.h>
-
-
-#define N 100
-
-static pthread_once_t once = PTHREAD_ONCE_INIT;
-
-static pthread_cond_t cond = PTHREAD_COND_INITIALIZER;
-static pthread_mutex_t mut = PTHREAD_MUTEX_INITIALIZER;
-
-static pthread_barrier_t bar;
-
-static int global;
-static int cl_called;
-
-static void
-once_handler1 (void)
-{
- if (pthread_mutex_lock (&mut) != 0)
- {
- puts ("once_handler1: mutex_lock failed");
- exit (1);
- }
- puts ("once_handler1: locked");
-
- int r = pthread_barrier_wait (&bar);
- if (r != 0 && r!= PTHREAD_BARRIER_SERIAL_THREAD)
- {
- puts ("once_handler1: barrier_wait failed");
- exit (1);
- }
-
- puts ("once_handler1: going to wait on cond");
-
- pthread_cond_wait (&cond, &mut);
-
- /* We should never get here. */
- exit (42);
-}
-
-static void
-once_handler2 (void)
-{
- global = 1;
-}
-
-
-static void
-cl (void *arg)
-{
- cl_called = 1;
-}
-
-
-static void *
-tf (void *arg)
-{
- pthread_cleanup_push (cl, NULL)
-
- pthread_once (&once, once_handler1);
-
- pthread_cleanup_pop (0);
-
- /* We should never get here. */
- puts ("pthread_once in tf returned");
- exit (1);
-}
-
-
-static int
-do_test (void)
-{
- pthread_t th;
-
- if (pthread_barrier_init (&bar, NULL, 2) != 0)
- {
- puts ("barrier_init failed");
- return 1;
- }
-
- if (pthread_create (&th, NULL, tf, NULL) != 0)
- {
- puts ("first create failed");
- return 1;
- }
-
- int r = pthread_barrier_wait (&bar);
- if (r != 0 && r!= PTHREAD_BARRIER_SERIAL_THREAD)
- {
- puts ("barrier_wait failed");
- return 1;
- }
-
- if (pthread_mutex_lock (&mut) != 0)
- {
- puts ("mutex_lock failed");
- return 1;
- }
- /* We unlock the mutex so that we catch the case where the pthread_cond_wait
- call incorrectly resumes and tries to get the mutex. */
- if (pthread_mutex_unlock (&mut) != 0)
- {
- puts ("mutex_unlock failed");
- return 1;
- }
-
- /* Cancel the thread. */
- puts ("going to cancel");
- if (pthread_cancel (th) != 0)
- {
- puts ("cancel failed");
- return 1;
- }
-
- void *result;
- pthread_join (th, &result);
- if (result != PTHREAD_CANCELED)
- {
- puts ("join didn't return PTHREAD_CANCELED");
- return 1;
- }
- puts ("joined successfully");
-
- printf ("once = %d\n", *(int *) &once);
-
- if (cl_called != 1)
- {
- puts ("cleanup handler not called");
- return 1;
- }
-
- pthread_once (&once, once_handler2);
-
- if (global != 1)
- {
- puts ("global still 0");
- return 1;
- }
-
- return 0;
-}
-
-#define TEST_FUNCTION do_test ()
-#include "../test-skeleton.c"
diff --git a/nptl/tst-once4.c b/nptl/tst-once4.c
deleted file mode 100644
index abcb164552..0000000000
--- a/nptl/tst-once4.c
+++ /dev/null
@@ -1,200 +0,0 @@
-/* Copyright (C) 2003-2020 Free Software Foundation, Inc.
- This file is part of the GNU C Library.
- Contributed by Ulrich Drepper <drepper@redhat.com>, 2003.
-
- The GNU C Library is free software; you can redistribute it and/or
- modify it under the terms of the GNU Lesser General Public
- License as published by the Free Software Foundation; either
- version 2.1 of the License, or (at your option) any later version.
-
- The GNU C Library is distributed in the hope that it will be useful,
- but WITHOUT ANY WARRANTY; without even the implied warranty of
- MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
- Lesser General Public License for more details.
-
- You should have received a copy of the GNU Lesser General Public
- License along with the GNU C Library; if not, see
- <https://www.gnu.org/licenses/>. */
-
-#include <pthread.h>
-#include <stdio.h>
-#include <stdlib.h>
-#include <time.h>
-#include <unistd.h>
-
-
-static pthread_once_t once = PTHREAD_ONCE_INIT;
-
-static pthread_cond_t cond = PTHREAD_COND_INITIALIZER;
-static pthread_mutex_t mut = PTHREAD_MUTEX_INITIALIZER;
-
-static pthread_barrier_t bar;
-
-static int global;
-static int cl_called;
-
-static void
-once_handler1 (void)
-{
- if (pthread_mutex_lock (&mut) != 0)
- {
- puts ("once_handler1: mutex_lock failed");
- exit (1);
- }
-
- int r = pthread_barrier_wait (&bar);
- if (r != 0 && r!= PTHREAD_BARRIER_SERIAL_THREAD)
- {
- puts ("once_handler1: barrier_wait failed");
- exit (1);
- }
-
- pthread_cond_wait (&cond, &mut);
-
- /* We should never get here. */
-}
-
-
-static void
-once_handler2 (void)
-{
- global = 1;
-}
-
-
-static void
-cl (void *arg)
-{
- ++cl_called;
-}
-
-
-static void *
-tf1 (void *arg)
-{
- pthread_cleanup_push (cl, NULL);
-
- pthread_once (&once, once_handler1);
-
- pthread_cleanup_pop (0);
-
- /* We should never get here. */
- puts ("pthread_once in tf returned");
- exit (1);
-}
-
-
-static void *
-tf2 (void *arg)
-{
- pthread_cleanup_push (cl, NULL);
-
- int r = pthread_barrier_wait (&bar);
- if (r != 0 && r!= PTHREAD_BARRIER_SERIAL_THREAD)
- {
- puts ("once_handler2: barrier_wait failed");
- exit (1);
- }
-
- pthread_cleanup_pop (0);
-
- pthread_once (&once, once_handler2);
-
- return NULL;
-}
-
-
-static int
-do_test (void)
-{
- pthread_t th[2];
-
- if (pthread_barrier_init (&bar, NULL, 2) != 0)
- {
- puts ("barrier_init failed");
- return 1;
- }
-
- if (pthread_create (&th[0], NULL, tf1, NULL) != 0)
- {
- puts ("first create failed");
- return 1;
- }
-
- int r = pthread_barrier_wait (&bar);
- if (r != 0 && r!= PTHREAD_BARRIER_SERIAL_THREAD)
- {
- puts ("first barrier_wait failed");
- return 1;
- }
-
- if (pthread_mutex_lock (&mut) != 0)
- {
- puts ("mutex_lock failed");
- return 1;
- }
- /* We unlock the mutex so that we catch the case where the pthread_cond_wait
- call incorrectly resumes and tries to get the mutex. */
- if (pthread_mutex_unlock (&mut) != 0)
- {
- puts ("mutex_unlock failed");
- return 1;
- }
-
- if (pthread_create (&th[1], NULL, tf2, NULL) != 0)
- {
- puts ("second create failed");
- return 1;
- }
-
- r = pthread_barrier_wait (&bar);
- if (r != 0 && r!= PTHREAD_BARRIER_SERIAL_THREAD)
- {
- puts ("second barrier_wait failed");
- return 1;
- }
-
- /* Give the second thread a chance to reach the pthread_once call. */
- sleep (2);
-
- /* Cancel the thread. */
- if (pthread_cancel (th[0]) != 0)
- {
- puts ("cancel failed");
- return 1;
- }
-
- void *result;
- pthread_join (th[0], &result);
- if (result != PTHREAD_CANCELED)
- {
- puts ("first join didn't return PTHREAD_CANCELED");
- return 1;
- }
-
- puts ("joined first thread");
-
- pthread_join (th[1], &result);
- if (result != NULL)
- {
- puts ("second join didn't return PTHREAD_CANCELED");
- return 1;
- }
-
- if (global != 1)
- {
- puts ("global still 0");
- return 1;
- }
-
- if (cl_called != 1)
- {
- printf ("cl_called = %d\n", cl_called);
- return 1;
- }
-
- return 0;
-}
-
-#define TEST_FUNCTION do_test ()
-#include "../test-skeleton.c"
diff --git a/nptl/tst-oncex3.c b/nptl/tst-oncex3.c
deleted file mode 100644
index 08225b88dc..0000000000
--- a/nptl/tst-oncex3.c
+++ /dev/null
@@ -1 +0,0 @@
-#include "tst-once3.c"
diff --git a/nptl/tst-oncex4.c b/nptl/tst-oncex4.c
deleted file mode 100644
index 9b4d98f3f1..0000000000
--- a/nptl/tst-oncex4.c
+++ /dev/null
@@ -1 +0,0 @@
-#include "tst-once4.c"