aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Hilliard <james.hilliard1@gmail.com>2018-12-27 09:16:20 +0800
committerYu Watanabe <watanabe.yu+github@gmail.com>2018-12-28 12:17:06 +0900
commit46e63a2a3ed46ce97430ce38e4cc0798c57900eb (patch)
tree92e2d546c281fcb4694bad7ae7ac876251486529 /src/systemd
parentcore: support %j in unit dependency resolution (diff)
downloadsystemd-46e63a2a3ed46ce97430ce38e4cc0798c57900eb.tar.gz
systemd-46e63a2a3ed46ce97430ce38e4cc0798c57900eb.tar.bz2
systemd-46e63a2a3ed46ce97430ce38e4cc0798c57900eb.zip
meson: use cross compilation compatible c++ check
Diffstat (limited to 'src/systemd')
-rw-r--r--src/systemd/meson.build3
1 files changed, 1 insertions, 2 deletions
diff --git a/src/systemd/meson.build b/src/systemd/meson.build
index e0c967efc..75c48b07a 100644
--- a/src/systemd/meson.build
+++ b/src/systemd/meson.build
@@ -52,8 +52,7 @@ if cc.has_argument('-std=iso9899:2017')
opts += [['c', '-std=iso9899:2017']]
endif
-cxx = find_program('c++', required : false)
-if cxx.found()
+if add_languages('cpp', required : false)
opts += [['c++'],
['c++', '-std=c++98'],
['c++', '-std=c++11']]