summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenda Xu <heroxbd@gentoo.org>2012-05-18 17:36:48 +0900
committerBenda Xu <heroxbd@gentoo.org>2012-05-18 17:36:48 +0900
commitfb26a5c2df5e1fde31491ebeff69112712008353 (patch)
tree2f8414516404877c9df8e29df0c2b2536ab2bd5c /dev-python/numexpr/numexpr-1.4.2.ebuild
downloadandroid-fb26a5c2df5e1fde31491ebeff69112712008353.tar.gz
android-fb26a5c2df5e1fde31491ebeff69112712008353.tar.bz2
android-fb26a5c2df5e1fde31491ebeff69112712008353.zip
initial commit
Diffstat (limited to 'dev-python/numexpr/numexpr-1.4.2.ebuild')
-rw-r--r--dev-python/numexpr/numexpr-1.4.2.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/numexpr/numexpr-1.4.2.ebuild b/dev-python/numexpr/numexpr-1.4.2.ebuild
new file mode 100644
index 0000000..5e2a772
--- /dev/null
+++ b/dev-python/numexpr/numexpr-1.4.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/numexpr/numexpr-1.4.2.ebuild,v 1.1 2011/01/29 09:36:37 xarthisius Exp $
+
+EAPI=2
+
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+DESCRIPTION="Fast numerical array expression evaluator for Python and NumPy."
+HOMEPAGE="http://code.google.com/p/numexpr/ http://pypi.python.org/pypi/numexpr"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64-linux"
+IUSE="mkl"
+
+RDEPEND=">=dev-python/numpy-1.3.1
+ mkl? ( sci-libs/mkl )"
+DEPEND="${RDEPEND}
+ >=dev-python/setuptools-0.6_rc3
+ >=dev-util/scons-1.2.0-r1"
+
+RESTRICT_PYTHON_ABIS="3.*"
+
+src_prepare() {
+ # TODO: alternatively icc's mkl can be used but it fails for me
+ if use mkl; then
+ cat <<- EOF > "${S}"/site.cfg
+ [mkl]
+ library_dirs = ${MKLROOT}/lib/em64t
+ include_dirs = ${MKLROOT}/include
+ mkl_libs = mkl_solver_ilp64, mkl_intel_ilp64, \
+ mkl_intel_thread, mkl_core, iomp5
+ EOF
+ fi
+}
+
+src_test() {
+ testing() {
+ PYTHONPATH="$(ls -d build-${PYTHON_ABI}/lib.*)" "$(PYTHON)" ${PN}/tests/test_${PN}.py
+ }
+ python_execute_function testing
+}