summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2017-03-19 02:56:10 +0100
committerSebastian Pipping <sping@gentoo.org>2017-03-19 03:08:04 +0100
commit5a9a20c9aa2d6d27f1e50549294ba1055f40fd86 (patch)
tree0a79b632b1f9b8d41c2ec620ff4ed0c27f6359b2 /dev-python
parentdev-python/rinoh-typeface-texgyrepagella: 0.1.1 (diff)
downloadbetagarden-5a9a20c9aa2d6d27f1e50549294ba1055f40fd86.tar.gz
betagarden-5a9a20c9aa2d6d27f1e50549294ba1055f40fd86.tar.bz2
betagarden-5a9a20c9aa2d6d27f1e50549294ba1055f40fd86.zip
dev-python/rinoh-typeface-dejavuserif: 0.1.1
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/rinoh-typeface-dejavuserif/Manifest1
-rw-r--r--dev-python/rinoh-typeface-dejavuserif/files/rinoh-typeface-dejavuserif-0.1.1-circular.patch24
-rw-r--r--dev-python/rinoh-typeface-dejavuserif/metadata.xml7
-rw-r--r--dev-python/rinoh-typeface-dejavuserif/rinoh-typeface-dejavuserif-0.1.1.ebuild26
4 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/rinoh-typeface-dejavuserif/Manifest b/dev-python/rinoh-typeface-dejavuserif/Manifest
new file mode 100644
index 0000000..f6a2e71
--- /dev/null
+++ b/dev-python/rinoh-typeface-dejavuserif/Manifest
@@ -0,0 +1 @@
+DIST rinoh-typeface-dejavuserif-0.1.1.tar.gz 1665265 SHA256 ff0b236bdd69ef36c14887ac5078bbf1f14ae1ca403fc81b5426ba0bdfb13bea SHA512 4b3d4101791d78046132a6c64d175e9ea1063ea0fec361791dd516801b5fe2f1359d999790e6504a752c8787fce465c3b953dbd496288a349ab7aa953e6c40e0 WHIRLPOOL 3f2450fd07cdaab423e2c9c9a4280ab16e959ec533eda656480dacd8c4732830a85c64ee80ee9a3f12316dbd1f9ee321e0c836897960c83be0967ce9b34233ba
diff --git a/dev-python/rinoh-typeface-dejavuserif/files/rinoh-typeface-dejavuserif-0.1.1-circular.patch b/dev-python/rinoh-typeface-dejavuserif/files/rinoh-typeface-dejavuserif-0.1.1-circular.patch
new file mode 100644
index 0000000..372c1bc
--- /dev/null
+++ b/dev-python/rinoh-typeface-dejavuserif/files/rinoh-typeface-dejavuserif-0.1.1-circular.patch
@@ -0,0 +1,24 @@
+From b3a519e1d35cfb954d8af615aaf66427010c1dd7 Mon Sep 17 00:00:00 2001
+From: Sebastian Pipping <sebastian@pipping.org>
+Date: Sun, 19 Mar 2017 02:54:45 +0100
+Subject: [PATCH] Remove circular dependency on rinohtype
+
+---
+ setup.py | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/setup.py b/setup.py
+index 75f39a7..c2c8b89 100644
+--- a/setup.py
++++ b/setup.py
+@@ -24,7 +24,6 @@ setup(
+ packages=find_packages(),
+ package_data={PACKAGE_DIR: ['*.ttf', '*.txt', 'AUTHORS', 'BUGS', 'LICENSE',
+ 'NEWS', 'README.md']},
+- install_requires=['rinohtype'],
+ entry_points={
+ 'rinoh.typefaces':
+ ['{} = {}:typeface'.format(ENTRY_POINT_NAME, PACKAGE_DIR)]
+--
+2.12.0
+
diff --git a/dev-python/rinoh-typeface-dejavuserif/metadata.xml b/dev-python/rinoh-typeface-dejavuserif/metadata.xml
new file mode 100644
index 0000000..82b7b79
--- /dev/null
+++ b/dev-python/rinoh-typeface-dejavuserif/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>sping@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-python/rinoh-typeface-dejavuserif/rinoh-typeface-dejavuserif-0.1.1.ebuild b/dev-python/rinoh-typeface-dejavuserif/rinoh-typeface-dejavuserif-0.1.1.ebuild
new file mode 100644
index 0000000..bfb2dfb
--- /dev/null
+++ b/dev-python/rinoh-typeface-dejavuserif/rinoh-typeface-dejavuserif-0.1.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{4,5,6} )
+inherit distutils-r1
+
+DESCRIPTION="DejaVu Serif typeface for rinohtype"
+HOMEPAGE="https://github.com/brechtm/rinoh-typeface-dejavuserif"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BitstreamVera"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="${PYTHON_DEPS}"
+
+DOCS=(
+ README.rst
+)
+
+PATCHES=(
+ "${FILESDIR}"/${P}-circular.patch
+)