summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-01-25 08:35:18 +0100
committerJustin Lecher <jlec@gentoo.org>2016-01-25 08:35:18 +0100
commit0c26a88336e2353fe28b742bcc41e0827a1a85a6 (patch)
tree1f81ce7c292520e2af87f604bab4ee0b4716ea5c /dev-vcs
parentapp-misc/mdp: 1.0.4 (diff)
downloadbetagarden-0c26a88336e2353fe28b742bcc41e0827a1a85a6.tar.gz
betagarden-0c26a88336e2353fe28b742bcc41e0827a1a85a6.tar.bz2
betagarden-0c26a88336e2353fe28b742bcc41e0827a1a85a6.zip
dev-vcs/git-cola: Fix tests to latest HEAD
* add python3.5 support Package-Manager: portage-2.2.27 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/git-cola/git-cola-9999.ebuild18
1 files changed, 8 insertions, 10 deletions
diff --git a/dev-vcs/git-cola/git-cola-9999.ebuild b/dev-vcs/git-cola/git-cola-9999.ebuild
index 7f3b6e3..4492662 100644
--- a/dev-vcs/git-cola/git-cola-9999.ebuild
+++ b/dev-vcs/git-cola/git-cola-9999.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
-PYTHON_COMPAT=( python2_7 python3_{3,4} )
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
DISTUTILS_SINGLE_IMPL=true
inherit distutils-r1 git-r3 readme.gentoo virtualx
@@ -33,10 +33,6 @@ DEPEND="${RDEPEND}
test? ( dev-python/nose[${PYTHON_USEDEP}] )
"
-PATCHES=(
- "${FILESDIR}"/${P}-disable-live-tests.patch
-)
-
python_prepare_all() {
rm share/git-cola/bin/*askpass* || die
@@ -70,10 +66,12 @@ python_compile_all() {
}
python_test() {
- PYTHONPATH="${S}:${S}/build/lib:${PYTHONPATH}" LC_ALL="C" \
- VIRTUALX_COMMAND="nosetests --verbose --with-id --with-doctest \
- --exclude=sphinxtogithub" \
- virtualmake
+ PYTHONPATH="${S}:${S}/build/lib:${PYTHONPATH}" \
+ LC_ALL="C" \
+ GIT_COLA_NO_HISTORY=True \
+ virtx nosetests \
+ --verbose --with-id --with-doctest \
+ --exclude=sphinxtogithub
}
src_install() {