aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfred Wingate <parona@protonmail.com>2023-10-06 03:25:53 +0300
committerAlfred Wingate <parona@protonmail.com>2023-10-06 03:27:38 +0300
commitc7e5540703846d21e82b67e0e08ed5c1bb2e14a6 (patch)
tree5b67db01f7af941df160cbf7b871c1764bb6c198
parentReformat with isort (diff)
downloadelogv-c7e5540703846d21e82b67e0e08ed5c1bb2e14a6.tar.gz
elogv-c7e5540703846d21e82b67e0e08ed5c1bb2e14a6.tar.bz2
elogv-c7e5540703846d21e82b67e0e08ed5c1bb2e14a6.zip
pyproject.toml: Add ruff configuration
Signed-off-by: Alfred Wingate <parona@protonmail.com>
-rw-r--r--pyproject.toml5
1 files changed, 5 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 755d294..25bc44c 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -22,3 +22,8 @@ extend_exclude = "(man|po|.*.egg-info)"
[tool.isort]
profile = "black"
src_paths = ["elogv"]
+
+[tool.ruff]
+include = ["elogv", "setup.py"]
+# Ignore long line violations
+ignore = ["E501"]