aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven 'sleipnir' Rebhan <odinshorse@googlemail.com>2009-04-16 21:57:29 +0000
committerSven 'sleipnir' Rebhan <odinshorse@googlemail.com>2009-04-16 21:57:29 +0000
commit85e2d29639dfafff0c41b2295e16667af9ef7048 (patch)
tree2ff06c7152ec6e697b2c2f20e2e90739bd03f32d /dev-libs
parentFix http://gentoo.mindzoo.de/index.cgi/ticket/158 by adding gtk-docs-am to th... (diff)
downloadembedded-cross-85e2d29639dfafff0c41b2295e16667af9ef7048.tar.gz
embedded-cross-85e2d29639dfafff0c41b2295e16667af9ef7048.tar.bz2
embedded-cross-85e2d29639dfafff0c41b2295e16667af9ef7048.zip
dbus-glib is the latest version, so removing older stuff from the overlay.
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/dbus-glib/dbus-glib-0.76.ebuild72
-rw-r--r--dev-libs/dbus-glib/dbus-glib-0.78.ebuild70
-rw-r--r--dev-libs/dbus-glib/files/dbus-glib-0.78-as-needed.patch12
3 files changed, 0 insertions, 154 deletions
diff --git a/dev-libs/dbus-glib/dbus-glib-0.76.ebuild b/dev-libs/dbus-glib/dbus-glib-0.76.ebuild
deleted file mode 100644
index 1edb651..0000000
--- a/dev-libs/dbus-glib/dbus-glib-0.76.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/dbus-glib/dbus-glib-0.76.ebuild,v 1.1 2008/08/15 13:47:27 cardoe Exp $
-
-inherit eutils multilib autotools
-
-DESCRIPTION="D-Bus bindings for glib"
-HOMEPAGE="http://dbus.freedesktop.org/"
-SRC_URI="http://dbus.freedesktop.org/releases/${PN}/${P}.tar.gz"
-
-LICENSE="|| ( GPL-2 AFL-2.1 )"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
-IUSE="doc selinux debug"
-
-RDEPEND=">=sys-apps/dbus-1.1.0
- >=dev-libs/glib-2.6
- selinux? ( sys-libs/libselinux )
- >=dev-libs/libxml2-2.6.21"
- # expat code now sucks.. libxml2 is the default
-DEPEND="${RDEPEND}
- dev-util/pkgconfig
- doc? ( app-doc/doxygen app-text/xmlto )"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- epatch "${FILESDIR}"/${PN}-introspection.patch
-
- # If we are crosscompiling we have to use the host version of the
- # dbus-binding-tool, because it is executed during the make process.
- epatch "${FILESDIR}/${PN}-configurable-examples.patch"
- epatch "${FILESDIR}/${PN}-crosscompile-dbus-binding-tool.patch"
-
- eautoreconf || die "eautoreconf failed"
-}
-
-src_compile() {
- local myconf=""
-
- # We can skip the examples dir, because nothing of it is installed anyway
- myconf="${myconf} --disable-examples"
-
- econf \
- $(use_enable selinux) \
- $(use_enable debug verbose-mode) \
- $(use_enable debug checks) \
- $(use_enable debug asserts) \
- --with-xml=libxml \
- --with-system-pid-file=/var/run/dbus.pid \
- --with-system-socket=/var/run/dbus/system_bus_socket \
- --with-session-socket-dir=/tmp \
- --with-dbus-user=messagebus \
- --localstatedir=/var \
- $(use_enable doc doxygen-docs) \
- --disable-xml-docs \
- ${myconf} \
- || die "econf failed"
-
- # after the compile, it uses a selinuxfs interface to
- # check if the SELinux policy has the right support
- use selinux && addwrite /selinux/access
-
- emake || die "make failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "make install failed"
-
- dodoc AUTHORS ChangeLog HACKING NEWS README
-}
diff --git a/dev-libs/dbus-glib/dbus-glib-0.78.ebuild b/dev-libs/dbus-glib/dbus-glib-0.78.ebuild
deleted file mode 100644
index 8a96b8c..0000000
--- a/dev-libs/dbus-glib/dbus-glib-0.78.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/dbus-glib/dbus-glib-0.78.ebuild,v 1.4 2009/01/18 20:34:47 eva Exp $
-
-inherit eutils multilib autotools bash-completion
-
-DESCRIPTION="D-Bus bindings for glib"
-HOMEPAGE="http://dbus.freedesktop.org/"
-SRC_URI="http://dbus.freedesktop.org/releases/${PN}/${P}.tar.gz"
-
-LICENSE="|| ( GPL-2 AFL-2.1 )"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
-IUSE="bash-completion debug doc test"
-
-RDEPEND=">=sys-apps/dbus-1.1.0
- >=dev-libs/glib-2.10
- >=dev-libs/expat-1.95.8"
-DEPEND="${RDEPEND}
- dev-util/pkgconfig
- sys-devel/gettext
- doc? (
- app-doc/doxygen
- app-text/xmlto
- >=dev-util/gtk-doc-1.4 )
- dev-util/gtk-doc-am"
-
-BASH_COMPLETION_NAME="dbus"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${PN}-introspection.patch
-
- epatch "${FILESDIR}"/${P}-as-needed.patch
-
- # submitted upstream to bug #19325
- epatch "${FILESDIR}"/${P}-fix-building-tests.patch
-
- epatch "${FILESDIR}/${PN}-crosscompile-dbus-binding-tool.patch"
-
- eautoreconf
-}
-
-src_compile() {
- econf \
- $(use_enable bash-completion) \
- $(use_enable debug verbose-mode) \
- $(use_enable debug checks) \
- $(use_enable debug asserts) \
- $(use_enable test tests) \
- $(use_with test test-socket-dir "${T}"/dbus-test-socket) \
- --localstatedir=/var \
- $(use_enable doc doxygen-docs) \
- $(use_enable doc gtk-doc)
-
- emake || die "make failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "make install failed"
-
- dodoc AUTHORS ChangeLog HACKING NEWS README
-
- #FIXME: We need --with-bash-completion-dir
- if use bash-completion ; then
- dobashcompletion "${D}"/etc/profile.d/dbus-bash-completion.sh
- rm -rf "${D}"/etc/profile.d
- fi
-}
diff --git a/dev-libs/dbus-glib/files/dbus-glib-0.78-as-needed.patch b/dev-libs/dbus-glib/files/dbus-glib-0.78-as-needed.patch
deleted file mode 100644
index b7b2408..0000000
--- a/dev-libs/dbus-glib/files/dbus-glib-0.78-as-needed.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -ur dbus-glib-0.78.orig/dbus/Makefile.am dbus-glib-0.78/dbus/Makefile.am
---- dbus-glib-0.78.orig/dbus/Makefile.am 2008-12-23 15:55:22.000000000 +0100
-+++ dbus-glib-0.78/dbus/Makefile.am 2008-12-23 15:55:57.000000000 +0100
-@@ -104,7 +104,7 @@
-
- dbus_bash_completion_helper_SOURCES = \
- dbus-bash-completion-helper.c
--dbus_bash_completion_helper_LDADD=$(DBUS_LIBS) $(DBUS_GLIB_LIBS) -lexpat libdbus-gtool.la libdbus-glib-1.la
-+dbus_bash_completion_helper_LDADD=$(DBUS_LIBS) $(DBUS_GLIB_LIBS) libdbus-gtool.la -lexpat libdbus-glib-1.la
-
-
- EXTRA_DIST=dbus-gmarshal.list make-dbus-glib-error-switch.sh make-dbus-glib-error-enum.sh dbus-bash-completion.sh.in