aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaksim 'max_posedon' Melnikau <maxposedon@gmail.com>2009-03-16 22:55:35 +0000
committerMaksim 'max_posedon' Melnikau <maxposedon@gmail.com>2009-03-16 22:55:35 +0000
commitb782169a6186e7bf139667645d7170f4b7468c36 (patch)
tree4a18fc525b4b54a2021b20e1dae37461bd229a5d /sci-geosciences
parentorbit-2.14.17 cross compile fix (diff)
downloadembedded-cross-b782169a6186e7bf139667645d7170f4b7468c36.tar.gz
embedded-cross-b782169a6186e7bf139667645d7170f4b7468c36.tar.bz2
embedded-cross-b782169a6186e7bf139667645d7170f4b7468c36.zip
tangogps: add ~arm keyword, add fso-gps is default gps alternative
Diffstat (limited to 'sci-geosciences')
-rw-r--r--sci-geosciences/tangogps/Manifest3
-rw-r--r--sci-geosciences/tangogps/files/tangogps-0.9.5-Makefile.in-honour-docdir.patch11
-rw-r--r--sci-geosciences/tangogps/tangogps-0.9.6.ebuild43
3 files changed, 57 insertions, 0 deletions
diff --git a/sci-geosciences/tangogps/Manifest b/sci-geosciences/tangogps/Manifest
new file mode 100644
index 0000000..b09c4ee
--- /dev/null
+++ b/sci-geosciences/tangogps/Manifest
@@ -0,0 +1,3 @@
+AUX tangogps-0.9.5-Makefile.in-honour-docdir.patch 374 RMD160 2e5fc1dec9a64bbb03147bb7fbfd29780a4c99cd SHA1 291917242e5b3d42e784fa4fa03585cf9329668d SHA256 d27d7e1b77d85e8a099ea328da93d463de24707472c242bbbfa9e9d527521d00
+DIST tangogps-0.9.6.tar.gz 483451 RMD160 7597adf921085e26c27e52d0bbfcb4981dd61849 SHA1 80a2643c381ca253b8f64abb4677f8571881456e SHA256 e56a77325cdea8c274a39fcb79bd47919cbafa15d8009176538ec9a94f5e6e13
+EBUILD tangogps-0.9.6.ebuild 1026 RMD160 017aabf1842c1d3df3eb06c2b16c8b207c4157b6 SHA1 c6bf71f9d0f021ed7101529c3327ba9ccb101362 SHA256 c6af54d7f767101764e362a437a31304dd686c568ff69cf3c7b31392bd50b37c
diff --git a/sci-geosciences/tangogps/files/tangogps-0.9.5-Makefile.in-honour-docdir.patch b/sci-geosciences/tangogps/files/tangogps-0.9.5-Makefile.in-honour-docdir.patch
new file mode 100644
index 0000000..ff38a4e
--- /dev/null
+++ b/sci-geosciences/tangogps/files/tangogps-0.9.5-Makefile.in-honour-docdir.patch
@@ -0,0 +1,11 @@
+--- tangogps-0.9.5/Makefile.in 2009-02-01 13:33:31.000000000 +0100
++++ tangogps-0.9.5.orig/Makefile.in 2009-02-01 13:33:05.000000000 +0100
+@@ -221,7 +221,7 @@
+ sysconfdir = @sysconfdir@
+ target_alias = @target_alias@
+ SUBDIRS = po src pixmaps data
+-tangogpsdocdir = ${prefix}/doc/tangogps
++tangogpsdocdir = @docdir@
+ tangogpsdoc_DATA = \
+ README\
+ COPYING\
diff --git a/sci-geosciences/tangogps/tangogps-0.9.6.ebuild b/sci-geosciences/tangogps/tangogps-0.9.6.ebuild
new file mode 100644
index 0000000..91d63e8
--- /dev/null
+++ b/sci-geosciences/tangogps/tangogps-0.9.6.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/tangogps/tangogps-0.9.6.ebuild,v 1.2 2009/02/08 16:05:35 bangert Exp $
+
+inherit eutils
+
+DESCRIPTION="tangogps is an easy to use, fast and lightweight mapping
+application for use with or without GPS."
+HOMEPAGE="http://www.tangogps.org/"
+SRC_URI="http://www.tangogps.org/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="gps"
+
+RDEPEND="x11-libs/gtk+
+ sys-apps/dbus
+ gnome-base/gconf
+ net-misc/curl
+ media-libs/libexif
+ gps? ( || ( sci-geosciences/fso-gpsd >=sci-geosciences/gpsd-2.34 ) )
+ "
+DEPEND="sys-devel/gettext
+ ${RDEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${PN}-0.9.5-Makefile.in-honour-docdir.patch"
+}
+
+src_compile() {
+ econf \
+ --docdir=/usr/share/doc/${P} \
+ || die "Configure failed!"
+
+ emake || die "Make failed!"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+}