summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-08-22 02:40:41 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-08-22 02:40:41 +0000
commit00160903643501f2eaf6c9297071e1f1ce973a77 (patch)
tree3b1c327bb322077054b819aa1b221fbfb0b53c0d
parentFix argv[0] (bug #281971). (diff)
downloadeselect-python-00160903643501f2eaf6c9297071e1f1ce973a77.tar.gz
eselect-python-00160903643501f2eaf6c9297071e1f1ce973a77.tar.bz2
eselect-python-00160903643501f2eaf6c9297071e1f1ce973a77.zip
Add some variables to Makefile.in (bug #282142).
-rw-r--r--Makefile.in11
-rw-r--r--configure.ac4
2 files changed, 11 insertions, 4 deletions
diff --git a/Makefile.in b/Makefile.in
index 0de6349..33ee8c3 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -1,13 +1,18 @@
CC = @CC@
+CPPFLAGS = @CPPFLAGS@
+CFLAGS = @CFLAGS@
WARNINGS_FLAGS = -Wall -Wextra
+ASFLAGS = @ASFLAGS@
+LDFLAGS = @LDFLAGS@
+EXEEXT = @EXEEXT@
-all: python-wrapper
+all: python-wrapper$(EXEEXT)
-python-wrapper: config.h python-wrapper.c
+python-wrapper$(EXEEXT): config.h python-wrapper.c
$(CC) $(CPPFLAGS) $(CFLAGS) $(WARNINGS_FLAGS) $(ASFLAGS) $(LDFLAGS) -o $@ python-wrapper.c
clean:
- rm -fr python-wrapper
+ rm -fr python-wrapper$(EXEEXT)
distclean: clean
rm -fr config.h config.log config.status Makefile
diff --git a/configure.ac b/configure.ac
index 8aaf1b8..08061c0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,10 +1,12 @@
-AC_INIT([eselect-python], [20090920])
+AC_INIT([eselect-python], [20090824])
AC_PROG_CC
# strndup() was introduced in POSIX.1-2008.
AC_CHECK_FUNCS([strndup])
+AC_SUBST([ASFLAGS])
+
# Create output files.
AC_CONFIG_HEADERS([config.h])
AC_CONFIG_FILES([Makefile])