aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIoan-Adrian Ratiu <adrian.ratiu@ni.com>2016-12-21 16:07:27 +0200
committerIoan-Adrian Ratiu <adrian.ratiu@ni.com>2016-12-21 16:30:44 +0200
commit2edc3cf8799eecae9cc476611f1259923314f6f8 (patch)
tree22e055982df0a677e0aae1e152f4ab795615ad3b /configure.ac
parentconfigure.ac bump 3.2.1 (diff)
downloadeudev-2edc3cf8799eecae9cc476611f1259923314f6f8.tar.gz
eudev-2edc3cf8799eecae9cc476611f1259923314f6f8.tar.bz2
eudev-2edc3cf8799eecae9cc476611f1259923314f6f8.zip
configure.ac: add option to disable mtd_probe
FTL is not necessarily present on all kernels so it's useful to have an option to disable this. Signed-off-by: Ioan-Adrian Ratiu <adrian.ratiu@ni.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ff90fe488..52865a815 100644
--- a/configure.ac
+++ b/configure.ac
@@ -284,6 +284,14 @@ fi
AM_CONDITIONAL([ENABLE_RULE_GENERATOR], [test "x$enable_rule_generator" = xyes])
# ------------------------------------------------------------------------------
+# mtd_probe - autoloads FTL module for mtd devices
+# ------------------------------------------------------------------------------
+AC_ARG_ENABLE([mtd_probe],
+ AS_HELP_STRING([--disable-mtd_probe], [disable MTD support]),
+ [], [enable_mtd_probe=yes])
+AM_CONDITIONAL([ENABLE_MTD_PROBE], [test "x$enable_mtd_probe" = xyes])
+
+# ------------------------------------------------------------------------------
AC_CONFIG_FILES([Makefile
hwdb/Makefile