aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Ruppert <idl0r@gentoo.org>2010-10-11 22:00:07 +0200
committerChristian Ruppert <idl0r@gentoo.org>2010-10-11 22:00:07 +0200
commitefcbec749f6955ee3c6d167847b34edc2360ecd9 (patch)
tree57af1b898dc93315677cc964da6dd31045a8a5a0
parentBump version to 1.1, tag v1.1. (diff)
downloadfifo-cronolog-efcbec749f6955ee3c6d167847b34edc2360ecd9.tar.gz
fifo-cronolog-efcbec749f6955ee3c6d167847b34edc2360ecd9.tar.bz2
fifo-cronolog-efcbec749f6955ee3c6d167847b34edc2360ecd9.zip
Rename everything from squid-cronolog to fifo-cronolog.
-rw-r--r--Makefile8
-rw-r--r--fifo-cronolog.c (renamed from squid-cronolog.c)2
-rw-r--r--fifo-cronolog.confd8
-rw-r--r--fifo-cronolog.initd (renamed from squid-cronolog.initd)12
-rw-r--r--squid-cronolog.confd4
5 files changed, 17 insertions, 17 deletions
diff --git a/Makefile b/Makefile
index e6a5f5e..cca4e8b 100644
--- a/Makefile
+++ b/Makefile
@@ -1,14 +1,14 @@
CFLAGS += -Wall
-all: squid-cronolog
+all: fifo-cronolog
-squid-cronolog: squid-cronolog.o
+fifo-cronolog: fifo-cronolog.o
$(CC) $(LDFLAGS) -o $@ $<
-squid-cronolog.o: squid-cronolog.c
+fifo-cronolog.o: fifo-cronolog.c
$(CC) $(CFLAGS) -c -o $@ $<
clean:
- $(RM) squid-cronolog{,.o}
+ $(RM) fifo-cronolog{,.o}
# vim: set ts=4 sw=4 tw=80:
diff --git a/squid-cronolog.c b/fifo-cronolog.c
index 07358b5..ef5609d 100644
--- a/squid-cronolog.c
+++ b/fifo-cronolog.c
@@ -95,7 +95,7 @@ int main(int argc, char *argv[]) {
if (argc != 4) {
fprintf(stderr, "Usage: %s /path/to/pidfile /path/to/fifo"
" /path/to/logs/%%Y%%m%%d.log\n", argv[0]);
- fprintf(stderr, "squid-cronolog version: %s\n", VERSION);
+ fprintf(stderr, "fifo-cronolog version: %s\n", VERSION);
exit(1);
}
diff --git a/fifo-cronolog.confd b/fifo-cronolog.confd
new file mode 100644
index 0000000..9eec589
--- /dev/null
+++ b/fifo-cronolog.confd
@@ -0,0 +1,8 @@
+# Various paths:
+PIDFILE="/var/run/fifo-cronolog.pid"
+FIFO="/var/lib/fifo-cronolog.fifo"
+LOGS="/var/log/fifo-cronolog/transfer/%Y%m%d.log"
+
+# Uncomment and add the service name you want to use it for to ensure
+# fifo-cronolog start first.
+#rc_fifo_cronolog_before="squid varnish"
diff --git a/squid-cronolog.initd b/fifo-cronolog.initd
index 484232c..e04b272 100644
--- a/squid-cronolog.initd
+++ b/fifo-cronolog.initd
@@ -3,20 +3,16 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-depend() {
- before squid
-}
-
start() {
- ebegin "Starting squid-cronolog"
- start-stop-daemon --start --exec /usr/sbin/squid-cronolog \
+ ebegin "Starting fifo-cronolog"
+ start-stop-daemon --start --exec /usr/sbin/fifo-cronolog \
--pidfile "${PIDFILE}" -- "${PIDFILE}" "${FIFO}" "${LOGS}"
eend $?
}
stop() {
- ebegin "Stopping squid-cronolog"
- start-stop-daemon --stop --exec /usr/sbin/squid-cronolog \
+ ebegin "Stopping fifo-cronolog"
+ start-stop-daemon --stop --exec /usr/sbin/fifo-cronolog \
--pidfile "${PIDFILE}"
eend $?
}
diff --git a/squid-cronolog.confd b/squid-cronolog.confd
deleted file mode 100644
index 6b5a2c1..0000000
--- a/squid-cronolog.confd
+++ /dev/null
@@ -1,4 +0,0 @@
-# Various paths:
-PIDFILE="/var/run/squid-cronolog.pid"
-FIFO="/var/lib/squid-cronolog.fifo"
-LOGS="/var/log/squid/transfer/%Y%m%d.log"