aboutsummaryrefslogtreecommitdiff
path: root/4.5.0
diff options
context:
space:
mode:
authorLuca Barbato <lu_zero@gentoo.org>2010-07-27 10:35:04 +0000
committerLuca Barbato <lu_zero@gentoo.org>2010-07-27 10:35:04 +0000
commitcf836ba7c2790153c78296155af74c53374295b9 (patch)
tree1156f28714883071a01cd83b78cb7875cdc10168 /4.5.0
parentPush 4.5.0 p1.4. (diff)
downloadgcc-patches-cf836ba7c2790153c78296155af74c53374295b9.tar.gz
gcc-patches-cf836ba7c2790153c78296155af74c53374295b9.tar.bz2
gcc-patches-cf836ba7c2790153c78296155af74c53374295b9.zip
Fix properly precompiled headers generation
Diffstat (limited to '4.5.0')
-rw-r--r--4.5.0/gentoo/94_all_gcc-4.3.3-pch-nostdinc-tr1.patch22
-rw-r--r--4.5.0/gentoo/94_all_gcc-4.5-pch-nostdinc.patch28
-rw-r--r--4.5.0/gentoo/README.history3
3 files changed, 31 insertions, 22 deletions
diff --git a/4.5.0/gentoo/94_all_gcc-4.3.3-pch-nostdinc-tr1.patch b/4.5.0/gentoo/94_all_gcc-4.3.3-pch-nostdinc-tr1.patch
deleted file mode 100644
index 86689e1..0000000
--- a/4.5.0/gentoo/94_all_gcc-4.3.3-pch-nostdinc-tr1.patch
+++ /dev/null
@@ -1,22 +0,0 @@
---- gcc-4.3.3/libstdc++-v3/include/Makefile.am.orig
-+++ gcc-4.3.3/libstdc++-v3/include/Makefile.am
-@@ -1084,7 +1084,7 @@
- # Build a precompiled TR1 include, stdtr1c++.h.gch/O2.gch
- ${pch2_output}: ${pch2_source} ${pch1_output}
- -mkdir -p ${pch2_output_builddir}
-- $(CXX) $(PCHFLAGS) $(AM_CPPFLAGS) -O2 -g ${pch2_source} -o $@
-+ $(CXX) $(PCHFLAGS) $(AM_CPPFLAGS) -nostdinc++ -O2 -g ${pch2_source} -o $@
-
- # Build a precompiled extension include, extc++.h.gch/O2.gch
- ${pch3_output}: ${pch3_source} ${pch2_output}
---- gcc-4.3.3/libstdc++-v3/include/Makefile.in.orig
-+++ gcc-4.3.3/libstdc++-v3/include/Makefile.in
-@@ -1475,7 +1475,7 @@
- # Build a precompiled TR1 include, stdtr1c++.h.gch/O2.gch
- ${pch2_output}: ${pch2_source} ${pch1_output}
- -mkdir -p ${pch2_output_builddir}
-- $(CXX) $(PCHFLAGS) $(AM_CPPFLAGS) -O2 -g ${pch2_source} -o $@
-+ $(CXX) $(PCHFLAGS) $(AM_CPPFLAGS) -nostdinc++ -O2 -g ${pch2_source} -o $@
-
- # Build a precompiled extension include, extc++.h.gch/O2.gch
- ${pch3_output}: ${pch3_source} ${pch2_output}
diff --git a/4.5.0/gentoo/94_all_gcc-4.5-pch-nostdinc.patch b/4.5.0/gentoo/94_all_gcc-4.5-pch-nostdinc.patch
new file mode 100644
index 0000000..023b522
--- /dev/null
+++ b/4.5.0/gentoo/94_all_gcc-4.5-pch-nostdinc.patch
@@ -0,0 +1,28 @@
+Make precompiled headers cross buildable.
+
+http://bugs.gentoo.org/show_bug.cgi?id=262912
+
+diff -urN gcc-4.5.0.orig//libstdc++-v3/include/Makefile.am gcc-4.5.0/libstdc++-v3/include/Makefile.am
+--- gcc-4.5.0.orig//libstdc++-v3/include/Makefile.am 2010-07-27 11:22:34.000000000 +0200
++++ gcc-4.5.0/libstdc++-v3/include/Makefile.am 2010-07-27 11:21:29.000000000 +0200
+@@ -893,7 +893,7 @@
+ ${pch1_output_builddir} ${pch2_output_builddir} ${pch3_output_builddir}
+ pch_output_anchors = \
+ ${pch1_output_anchor} ${pch2_output_anchor} ${pch3_output_anchor}
+-PCHFLAGS=-x c++-header $(CXXFLAGS)
++PCHFLAGS=-x c++-header $(CXXFLAGS) -nostdinc++
+ if GLIBCXX_BUILD_PCH
+ pch_build = ${pch_output}
+ else
+diff -urN gcc-4.5.0.orig//libstdc++-v3/include/Makefile.in gcc-4.5.0/libstdc++-v3/include/Makefile.in
+--- gcc-4.5.0.orig//libstdc++-v3/include/Makefile.in 2010-04-02 20:18:06.000000000 +0200
++++ gcc-4.5.0/libstdc++-v3/include/Makefile.in 2010-07-27 11:21:47.000000000 +0200
+@@ -1119,7 +1119,7 @@
+ pch_output_anchors = \
+ ${pch1_output_anchor} ${pch2_output_anchor} ${pch3_output_anchor}
+
+-PCHFLAGS = -x c++-header $(CXXFLAGS)
++PCHFLAGS = -x c++-header $(CXXFLAGS) -nostdinc++
+ @GLIBCXX_BUILD_PCH_FALSE@pch_build =
+ @GLIBCXX_BUILD_PCH_TRUE@pch_build = ${pch_output}
+
diff --git a/4.5.0/gentoo/README.history b/4.5.0/gentoo/README.history
index 9345007..778d120 100644
--- a/4.5.0/gentoo/README.history
+++ b/4.5.0/gentoo/README.history
@@ -1,3 +1,6 @@
+ + 94_all_gcc-4.5-pch-nostdinc.patch
+ - 94_all_gcc-4.3.3-pch-nostdinc-tr1.patch
+
1.4 25.07.2010
U 75_all_arm-pr43698.patch
+ 93_all_gcc-4.5-cloog-dl.patch