aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2012-11-02 17:15:07 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2012-11-02 17:18:45 +0000
commit71507545eec3031ade9b4f9a314c53216f2c97f2 (patch)
tree4214312ec75554b79133b0dda9f753cace2fa34a /Makefile
parentBug #378105: UUID/LABEL support for LUKS keydevs (diff)
downloadgenkernel-71507545eec3031ade9b4f9a314c53216f2c97f2.tar.gz
genkernel-71507545eec3031ade9b4f9a314c53216f2c97f2.tar.bz2
genkernel-71507545eec3031ade9b4f9a314c53216f2c97f2.zip
Move to autogenerated ChangeLog.
Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/Makefile b/Makefile
index 751bb46..8e31a06 100644
--- a/Makefile
+++ b/Makefile
@@ -2,20 +2,23 @@ PACKAGE_VERSION = `/bin/fgrep GK_V= genkernel | sed "s/.*GK_V='\([^']\+\)'/\1/"`
distdir = genkernel-$(PACKAGE_VERSION)
# Add off-Git/generated files here that need to be shipped with releases
-EXTRA_DIST = genkernel.8
+EXTRA_DIST = genkernel.8 ChangeLog
genkernel.8: doc/genkernel.8.txt doc/asciidoc.conf Makefile genkernel
a2x --conf-file=doc/asciidoc.conf --attribute="genkernelversion=$(PACKAGE_VERSION)" \
--format=manpage -D . "$<"
+ChangeLog:
+ git log >$@
+
clean:
- rm -f genkernel.8
+ rm -f $(EXTRA_DIST)
check-git-repository:
git diff --quiet || { echo 'STOP, you have uncommitted changes in the working directory' ; false ; }
git diff --cached --quiet || { echo 'STOP, you have uncommitted changes in the index' ; false ; }
-dist: check-git-repository genkernel.8
+dist: check-git-repository $(EXTRA_DIST)
rm -Rf "$(distdir)" "$(distdir)".tar "$(distdir)".tar.bz2
mkdir "$(distdir)"
git ls-files -z | xargs -0 cp --no-dereference --parents --target-directory="$(distdir)" \