summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNP-Hardass <NP-Hardass@gentoo.org>2016-04-10 23:34:26 -0400
committerNP-Hardass <NP-Hardass@gentoo.org>2016-06-17 13:34:27 -0400
commitf9e0281bc76f91460afed542a21c9d9d0035685c (patch)
tree16d367774fbd062b6709939adffd4b7bee507196 /x11-misc
parentx11-themes/mate-themes-meta: Version bump to 1.12, add 9999 (diff)
downloadgentoo-mate-f9e0281bc76f91460afed542a21c9d9d0035685c.tar.gz
gentoo-mate-f9e0281bc76f91460afed542a21c9d9d0035685c.tar.bz2
gentoo-mate-f9e0281bc76f91460afed542a21c9d9d0035685c.zip
x11-misc/mate-notification-daemon: Bump to 1.12.1, add 9999, add gtk3
Package-Manager: portage-2.2.26
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/mate-notification-daemon/Manifest1
-rw-r--r--x11-misc/mate-notification-daemon/files/org.freedesktop.Notification.service3
-rw-r--r--x11-misc/mate-notification-daemon/files/org.freedesktop.Notifications.service3
-rw-r--r--x11-misc/mate-notification-daemon/mate-notification-daemon-1.12.1.ebuild62
-rw-r--r--x11-misc/mate-notification-daemon/mate-notification-daemon-9999.ebuild62
-rw-r--r--x11-misc/mate-notification-daemon/metadata.xml3
6 files changed, 134 insertions, 0 deletions
diff --git a/x11-misc/mate-notification-daemon/Manifest b/x11-misc/mate-notification-daemon/Manifest
index e4cd852..f267c7b 100644
--- a/x11-misc/mate-notification-daemon/Manifest
+++ b/x11-misc/mate-notification-daemon/Manifest
@@ -1 +1,2 @@
DIST mate-notification-daemon-1.10.2.tar.xz 304100 SHA256 f421deaf684368cc426954bbd6ecd1aa518fa50f44c03e0f68a50ae8aa9b35b3 SHA512 6b7cc9c7450da340c2a6061307c46a0fdabb4ff28fd6dfa12180f4007fcd33ea936d767abae19c571e6f63fa8a261df40dfc2bfb38d8efebbe9becc4ba16dbcc WHIRLPOOL fba269bdf8a0ad37889b9ebaf4d2da95835187714ce958989ca76471a82afdd1ed4970fe520936d59b8a961988b05f557cce32235e4a37eae355b980045b1b1b
+DIST mate-notification-daemon-1.12.1.tar.xz 304752 SHA256 856bad2bb90e2b7d1124c0ae197c07a321b3cc2767897b3e6b78e59a3096a7dd SHA512 ce9cd1737cc70b0e17fa856730b51747f78bb40639ff58e205a3f1432edf53aba38442d59b7a4fca6ff460cbdc6c611c0a05a46bbf5db92db0ce5e714e19daae WHIRLPOOL b925ac68692f1535bc57bed23f9c19239583c5ca674e5f6493223d31ff6be6ca2bb94b89cdb12baa0eafcaad1cf1c3d6df7ee717b71730b6947be0c0c81a22cd
diff --git a/x11-misc/mate-notification-daemon/files/org.freedesktop.Notification.service b/x11-misc/mate-notification-daemon/files/org.freedesktop.Notification.service
new file mode 100644
index 0000000..c0d96af
--- /dev/null
+++ b/x11-misc/mate-notification-daemon/files/org.freedesktop.Notification.service
@@ -0,0 +1,3 @@
+[D-BUS Service]
+Name=org.freedesktop.Notifications
+Exec=/usr/libexec/mate-notification-daemon
diff --git a/x11-misc/mate-notification-daemon/files/org.freedesktop.Notifications.service b/x11-misc/mate-notification-daemon/files/org.freedesktop.Notifications.service
new file mode 100644
index 0000000..c0d96af
--- /dev/null
+++ b/x11-misc/mate-notification-daemon/files/org.freedesktop.Notifications.service
@@ -0,0 +1,3 @@
+[D-BUS Service]
+Name=org.freedesktop.Notifications
+Exec=/usr/libexec/mate-notification-daemon
diff --git a/x11-misc/mate-notification-daemon/mate-notification-daemon-1.12.1.ebuild b/x11-misc/mate-notification-daemon/mate-notification-daemon-1.12.1.ebuild
new file mode 100644
index 0000000..b316396
--- /dev/null
+++ b/x11-misc/mate-notification-daemon/mate-notification-daemon-1.12.1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+MATE_LA_PUNT="yes"
+
+inherit mate
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+DESCRIPTION="MATE Notification daemon"
+LICENSE="GPL-2"
+SLOT="0"
+
+IUSE="gtk3"
+
+RDEPEND="
+ dev-libs/atk:0
+ >=dev-libs/dbus-glib-0.78:0
+ >=dev-libs/glib-2.36:2
+ >=sys-apps/dbus-1:0
+ x11-libs/cairo:0
+ >=x11-libs/gdk-pixbuf-2.22:2
+ >=x11-libs/libnotify-0.7:0
+ x11-libs/libX11:0
+ virtual/libintl:0
+ !gtk3? (
+ >=x11-libs/gtk+-2.24:2
+ >=x11-libs/libwnck-1:1
+ >=media-libs/libcanberra-0.4:0[gtk]
+ )
+ gtk3? (
+ >=x11-libs/gtk+-3.0:3
+ >=x11-libs/libwnck-3:3
+ >=media-libs/libcanberra-0.4:0[gtk3]
+ )
+ !x11-misc/notify-osd:*
+ !x11-misc/qtnotifydaemon:*
+ !x11-misc/notification-daemon:*"
+
+DEPEND="${RDEPEND}
+ app-arch/xz-utils:0
+ >=dev-util/intltool-0.50.1:*
+ sys-devel/gettext:*
+ >=sys-devel/libtool-2.2.6:2
+ virtual/pkgconfig:*"
+
+src_configure() {
+ mate_src_configure \
+ --with-gtk=$(usex gtk3 3.0 2.0)
+}
+
+src_install() {
+ mate_src_install
+
+ insinto /usr/share/dbus-1/services
+ doins "${FILESDIR}/org.freedesktop.Notifications.service"
+}
diff --git a/x11-misc/mate-notification-daemon/mate-notification-daemon-9999.ebuild b/x11-misc/mate-notification-daemon/mate-notification-daemon-9999.ebuild
new file mode 100644
index 0000000..b316396
--- /dev/null
+++ b/x11-misc/mate-notification-daemon/mate-notification-daemon-9999.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+MATE_LA_PUNT="yes"
+
+inherit mate
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+DESCRIPTION="MATE Notification daemon"
+LICENSE="GPL-2"
+SLOT="0"
+
+IUSE="gtk3"
+
+RDEPEND="
+ dev-libs/atk:0
+ >=dev-libs/dbus-glib-0.78:0
+ >=dev-libs/glib-2.36:2
+ >=sys-apps/dbus-1:0
+ x11-libs/cairo:0
+ >=x11-libs/gdk-pixbuf-2.22:2
+ >=x11-libs/libnotify-0.7:0
+ x11-libs/libX11:0
+ virtual/libintl:0
+ !gtk3? (
+ >=x11-libs/gtk+-2.24:2
+ >=x11-libs/libwnck-1:1
+ >=media-libs/libcanberra-0.4:0[gtk]
+ )
+ gtk3? (
+ >=x11-libs/gtk+-3.0:3
+ >=x11-libs/libwnck-3:3
+ >=media-libs/libcanberra-0.4:0[gtk3]
+ )
+ !x11-misc/notify-osd:*
+ !x11-misc/qtnotifydaemon:*
+ !x11-misc/notification-daemon:*"
+
+DEPEND="${RDEPEND}
+ app-arch/xz-utils:0
+ >=dev-util/intltool-0.50.1:*
+ sys-devel/gettext:*
+ >=sys-devel/libtool-2.2.6:2
+ virtual/pkgconfig:*"
+
+src_configure() {
+ mate_src_configure \
+ --with-gtk=$(usex gtk3 3.0 2.0)
+}
+
+src_install() {
+ mate_src_install
+
+ insinto /usr/share/dbus-1/services
+ doins "${FILESDIR}/org.freedesktop.Notifications.service"
+}
diff --git a/x11-misc/mate-notification-daemon/metadata.xml b/x11-misc/mate-notification-daemon/metadata.xml
index 9832314..955e459 100644
--- a/x11-misc/mate-notification-daemon/metadata.xml
+++ b/x11-misc/mate-notification-daemon/metadata.xml
@@ -5,6 +5,9 @@
<email>mate@gentoo.org</email>
<name>Gentoo MATE Desktop</name>
</maintainer>
+ <use>
+ <flag name="gtk3">Build with GTK+3 instead of GTK+2</flag>
+ </use>
<upstream>
<remote-id type="github">mate-desktop/mate-notification-daemon</remote-id>
</upstream>