summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2019-02-23 22:18:30 +0200
committerMart Raudsepp <leio@gentoo.org>2019-02-23 22:18:30 +0200
commit8cd6f5153e287ea4fb6a52823273b6a0f57a5017 (patch)
treede7b63707a461676614c71cccc52efc3b9817f5c
parentgnome-extra/gnome-contacts: remove 3.26, available in ::gentoo (diff)
downloadgnome-8cd6f5153e287ea4fb6a52823273b6a0f57a5017.tar.gz
gnome-8cd6f5153e287ea4fb6a52823273b6a0f57a5017.tar.bz2
gnome-8cd6f5153e287ea4fb6a52823273b6a0f57a5017.zip
gnome-extra/gnome-contacts-9999: blind sync live ebuild
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
-rw-r--r--gnome-extra/gnome-contacts/gnome-contacts-9999.ebuild68
-rw-r--r--gnome-extra/gnome-contacts/metadata.xml3
2 files changed, 36 insertions, 35 deletions
diff --git a/gnome-extra/gnome-contacts/gnome-contacts-9999.ebuild b/gnome-extra/gnome-contacts/gnome-contacts-9999.ebuild
index e68bf5bb..871df7cb 100644
--- a/gnome-extra/gnome-contacts/gnome-contacts-9999.ebuild
+++ b/gnome-extra/gnome-contacts/gnome-contacts-9999.ebuild
@@ -1,78 +1,76 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-VALA_USE_DEPEND="vapigen"
-VALA_MIN_API_VERSION="0.24"
-inherit git-r3 gnome-meson vala
+inherit gnome.org gnome2-utils meson vala xdg
DESCRIPTION="GNOME contact management application"
HOMEPAGE="https://wiki.gnome.org/Design/Apps/Contacts"
-SRC_URI=""
-EGIT_REPO_URI="https://gitlab.gnome.org/GNOME/gnome-contacts.git"
LICENSE="GPL-2+"
SLOT="0"
-IUSE="v4l"
+IUSE="telepathy v4l"
if [[ ${PV} = 9999 ]]; then
- KEYWORDS=""
+ inherit git-r3
+ SRC_URI=""
+ EGIT_REPO_URI="https://gitlab.gnome.org/GNOME/gnome-contacts.git"
else
KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
fi
VALA_DEPEND="
$(vala_depend)
- >=dev-libs/gobject-introspection-0.9.6:=
+ >=dev-libs/gobject-introspection-1.54
dev-libs/folks[vala(+)]
- gnome-base/gnome-desktop:3=[introspection]
+ net-libs/gnome-online-accounts[vala]
gnome-extra/evolution-data-server[vala]
net-libs/telepathy-glib[vala]
"
# Configure is wrong; it needs cheese-3.5.91, not 3.3.91
RDEPEND="
- >=dev-libs/folks-0.11.4:=[eds,telepathy]
+ >=gnome-extra/evolution-data-server-3.13.90:=[gnome-online-accounts]
+ >=dev-libs/folks-0.11.4:=[eds,telepathy?]
>=dev-libs/glib-2.44:2
>=dev-libs/libgee-0.10:0.8
- >=gnome-extra/evolution-data-server-3.13.90:=[gnome-online-accounts]
>=gnome-base/gnome-desktop-3.0:3=
- media-libs/clutter:1.0
- media-libs/clutter-gtk:1.0
- media-libs/libchamplain:0.12
- net-libs/gnome-online-accounts:=[vala]
- >=net-libs/telepathy-glib-0.22
- >=sci-geosciences/geocode-glib-3.15.3
- x11-libs/cairo:=
- x11-libs/gdk-pixbuf:2
+ net-libs/gnome-online-accounts:=
>=x11-libs/gtk+-3.22:3
- x11-libs/pango
v4l? ( >=media-video/cheese-3.5.91:= )
+ telepathy? ( >=net-libs/telepathy-glib-0.22 )
"
DEPEND="${RDEPEND}
${VALA_DEPEND}
app-text/docbook-xml-dtd:4.2
app-text/docbook-xsl-stylesheets
+ dev-libs/appstream-glib
+ dev-libs/libxml2:2
dev-libs/libxslt
- >=sys-devel/gettext-0.17
+ >=sys-devel/gettext-0.19.8
virtual/pkgconfig
"
-src_unpack() {
- git-r3_src_unpack
-}
-
src_prepare() {
- # Regenerate the pre-generated C sources, bug #471628
- if ! use v4l; then
- touch src/*.vala
- fi
-
+ xdg_src_prepare
vala_src_prepare
- gnome-meson_src_prepare
}
src_configure() {
- gnome-meson_src_configure \
- -Dwith-manpage=true \
- $(meson_use v4l with-cheese)
+ local emesonargs=(
+ $(meson_use v4l cheese)
+ $(meson_use telepathy)
+ -Dmanpage=true
+ -Ddocs=false
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
}
diff --git a/gnome-extra/gnome-contacts/metadata.xml b/gnome-extra/gnome-contacts/metadata.xml
index 39980802..03d1d32c 100644
--- a/gnome-extra/gnome-contacts/metadata.xml
+++ b/gnome-extra/gnome-contacts/metadata.xml
@@ -5,4 +5,7 @@
<email>gnome@gentoo.org</email>
<name>Gentoo GNOME Desktop</name>
</maintainer>
+<use>
+ <flag name="telepathy">Start chat from contact details</flag>
+</use>
</pkgmetadata>