aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKenton Groombridge <me@concord.sh>2022-05-06 21:00:02 -0400
committerJason Zaman <perfinion@gentoo.org>2022-09-03 11:41:55 -0700
commit48e73e8265a37ee47d75d89fc03fb4231d07ca56 (patch)
tree84b37e873b934e89a153e4aac46d001194da2f77 /Makefile
parentudica-templates: initial commit of udica templates (diff)
downloadhardened-refpolicy-48e73e8265a37ee47d75d89fc03fb4231d07ca56.tar.gz
hardened-refpolicy-48e73e8265a37ee47d75d89fc03fb4231d07ca56.tar.bz2
hardened-refpolicy-48e73e8265a37ee47d75d89fc03fb4231d07ca56.zip
makefile: add install target for udica templates
Signed-off-by: Kenton Groombridge <me@concord.sh> Signed-off-by: Jason Zaman <perfinion@gentoo.org>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile15
1 files changed, 14 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 84c019f9..29d45af1 100644
--- a/Makefile
+++ b/Makefile
@@ -135,6 +135,9 @@ htmldir := $(LOCAL_ROOT)/doc/html
doctmpdir := $(LOCAL_ROOT)/doc/tmp
endif
+# udica templates path
+udicatemplates := udica-templates
+
# config file paths
globaltun := $(poldir)/global_tunables
globalbool := $(poldir)/global_booleans
@@ -169,6 +172,7 @@ sharedir := $(prefix)/share/selinux
modpkgdir := $(sharedir)/$(strip $(NAME))
headerdir := $(modpkgdir)/include
docsdir := $(prefix)/share/doc/$(PKGNAME)
+udicatemplatesdir := $(prefix)/share/udica/templates
# enable MLS if requested.
ifeq "$(TYPE)" "mls"
@@ -594,6 +598,15 @@ install-src:
########################################
#
+# Install udica templates
+#
+install-udica-templates:
+ @mkdir -p $(udicatemplatesdir)
+ @echo "Installing udica templates"
+ $(verbose) $(INSTALL) -m 644 $(wildcard $(udicatemplates)/*) $(udicatemplatesdir)
+
+########################################
+#
# Generate tags file
#
ctags: $(tags)
@@ -673,4 +686,4 @@ ifneq ($(generated_fc),)
endif
endif
-.PHONY: install-src install-appconfig install-headers build-interface-db generate xml conf html bare tags
+.PHONY: install-src install-appconfig install-headers install-udica-templates build-interface-db generate xml conf html bare tags