diff options
author | cgzones <cgzones@googlemail.com> | 2016-12-04 14:18:21 +0100 |
---|---|---|
committer | Jason Zaman <jason@perfinion.com> | 2016-12-06 20:39:33 +0800 |
commit | b8bf820c6d3245e858988c2d7db487252aba5248 (patch) | |
tree | ac47677652bce342b9fc6b4054cc5f41e46958ad /Makefile | |
parent | keep 2 empty lines in front of a new section (diff) | |
download | hardened-refpolicy-b8bf820c6d3245e858988c2d7db487252aba5248.tar.gz hardened-refpolicy-b8bf820c6d3245e858988c2d7db487252aba5248.tar.bz2 hardened-refpolicy-b8bf820c6d3245e858988c2d7db487252aba5248.zip |
using intermediate target instead of splitting up conf files generation
Diffstat (limited to 'Makefile')
-rw-r--r-- | Makefile | 17 |
1 files changed, 8 insertions, 9 deletions
@@ -2,7 +2,7 @@ # Makefile for the security policy. # # Targets: -# +# # install - compile and install the policy configuration, and context files. # load - compile, install, and load the policy configuration. # reload - compile, install, and load/reload the policy configuration. @@ -236,7 +236,7 @@ ifeq ($(DISTRO),debian) endif ifeq ($(DISTRO),gentoo) - CTAGS := exuberant-ctags + CTAGS := exuberant-ctags endif CTAGS ?= ctags @@ -393,13 +393,12 @@ $(net_contexts): $(moddir)/kernel/corenetwork.te.in # conf: $(mod_conf) $(booleans) generate -$(booleans): $(polxml) - @echo "Updating $(booleans)" - $(verbose) $(gendoc) -b $(booleans) -x $(polxml) +$(booleans) $(mod_conf): conf.intermediate -$(mod_conf): $(polxml) - @echo "Updating $(mod_conf)" - $(verbose) $(gendoc) -m $(mod_conf) -x $(polxml) +.INTERMEDIATE: conf.intermediate +conf.intermediate: $(polxml) + @echo "Updating $(booleans) and $(mod_conf)" + $(verbose) $(gendoc) -b $(booleans) -m $(mod_conf) -x $(polxml) ######################################## # @@ -418,7 +417,7 @@ $(layerxml): %.xml: $(all_metaxml) $(filter $(addprefix $(moddir)/, $(notdir $*) $(verbose) for i in $(basename $(filter $(addprefix $(moddir)/, $(notdir $*))%, $(detected_mods))); do $(genxml) -w -m $$i >> $@; done ifdef LOCAL_ROOT $(verbose) for i in $(basename $(filter $(addprefix $(local_moddir)/, $(notdir $*))%, $(detected_mods))); do $(genxml) -w -m $$i >> $@; done -endif +endif $(tunxml): $(globaltun) $(verbose) $(genxml) -w -t $< > $@ |