summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-08-24 16:54:44 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-11-30 01:51:52 +0100
commita517cb5cff245df31e917e92e672baf85049fcee (patch)
treec14a15ed02cea7921ae722712f65612ae642c4a6 /kde-plasma
parentmedia-sound/amarok: Cleanup metadata.xml (diff)
downloadkde-sunset-a517cb5cff245df31e917e92e672baf85049fcee.tar.gz
kde-sunset-a517cb5cff245df31e917e92e672baf85049fcee.tar.bz2
kde-sunset-a517cb5cff245df31e917e92e672baf85049fcee.zip
kde-plasma/plasma-workspace: Drop IUSE=python
Missing kde-apps/pykde4 and easier (non-)maintenance without python. Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma')
-rw-r--r--kde-plasma/plasma-workspace/plasma-workspace-4.11.22.ebuild31
1 files changed, 4 insertions, 27 deletions
diff --git a/kde-plasma/plasma-workspace/plasma-workspace-4.11.22.ebuild b/kde-plasma/plasma-workspace/plasma-workspace-4.11.22.ebuild
index 6a10a6e7..d9cebfb0 100644
--- a/kde-plasma/plasma-workspace/plasma-workspace-4.11.22.ebuild
+++ b/kde-plasma/plasma-workspace/plasma-workspace-4.11.22.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -7,16 +7,13 @@ DECLARATIVE_REQUIRED="always"
KDE_HANDBOOK="optional"
KMNAME="kde-workspace"
KMMODULE="plasma"
-PYTHON_COMPAT=( python2_7 )
OPENGL_REQUIRED="always"
WEBKIT_REQUIRED="always"
-inherit python-single-r1 kde4-meta
+inherit kde4-meta
DESCRIPTION="Plasma: KDE desktop framework"
KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
-IUSE="debug gps json +pim python qalculate"
-
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+IUSE="debug gps json +pim qalculate"
COMMONDEPEND="
dev-libs/libdbusmenu-qt[qt4]
@@ -38,11 +35,6 @@ COMMONDEPEND="
gps? ( >=sci-geosciences/gpsd-2.37 )
json? ( dev-libs/qjson )
pim? ( $(add_kdeapps_dep kdepimlibs) )
- python? (
- ${PYTHON_DEPS}
- >=dev-python/PyQt4-4.4.0[X,${PYTHON_SINGLE_USEDEP}]
- $(add_kdeapps_dep pykde4 "${PYTHON_SINGLE_USEDEP}")
- )
qalculate? ( sci-libs/libqalculate )
"
DEPEND="${COMMONDEPEND}
@@ -73,13 +65,6 @@ KMEXTRACTONLY="
ksysguard/
"
-pkg_setup() {
- if use python ; then
- python-single-r1_pkg_setup
- fi
- kde4-meta_pkg_setup
-}
-
src_unpack() {
if use handbook; then
KMEXTRA+=" doc/plasma-desktop"
@@ -91,23 +76,15 @@ src_unpack() {
src_configure() {
local mycmakeargs=(
-DWITH_NepomukCore=OFF
+ -DWITH_PythonLibrary=OFF
-DWITH_Soprano=OFF
-DWITH_Xmms=OFF
$(cmake-utils_use_with gps libgps)
$(cmake-utils_use_with json QJSON)
$(cmake-utils_use_with pim Akonadi)
$(cmake-utils_use_with pim KdepimLibs)
- $(cmake-utils_use_with python PythonLibrary)
$(cmake-utils_use_with qalculate)
)
kde4-meta_src_configure
}
-
-src_install() {
- kde4-meta_src_install
-
- if use python; then
- python_optimize "${ED}"
- fi
-}