aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-04-09 20:43:52 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2024-04-09 21:09:26 +0200
commit232ce35a8a5c3d2fbde5b638555e04276b4e144b (patch)
tree9b742a817feddd27323c15879054a5761c69b735 /kde-apps/thumbnailers
parentkde-apps/svgpart: 24.02.2 version bump (diff)
downloadkde-232ce35a8a5c3d2fbde5b638555e04276b4e144b.tar.gz
kde-232ce35a8a5c3d2fbde5b638555e04276b4e144b.tar.bz2
kde-232ce35a8a5c3d2fbde5b638555e04276b4e144b.zip
kde-apps/thumbnailers: 24.02.2 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/thumbnailers')
-rw-r--r--kde-apps/thumbnailers/Manifest1
-rw-r--r--kde-apps/thumbnailers/thumbnailers-24.02.2.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/kde-apps/thumbnailers/Manifest b/kde-apps/thumbnailers/Manifest
new file mode 100644
index 0000000000..30c33dcd89
--- /dev/null
+++ b/kde-apps/thumbnailers/Manifest
@@ -0,0 +1 @@
+DIST kdegraphics-thumbnailers-24.02.2.tar.xz 48664 BLAKE2B e6358c68a541d496a0be871303c2887c9d3e29283809cc248fcd3a0e4c5be590eb224b083dbed44c2bd4b946c69f48c2dcd1c2dbf3a2b37a8f20c13996718d71 SHA512 bdacb207bdf74fa12b694253caa9475241fee2e8dd55aeec8d195e59cdf24cb2109b02138a7725fe423b6359bd4ec482fb9441d2e24ca9e0640e7b5455fa4e1f
diff --git a/kde-apps/thumbnailers/thumbnailers-24.02.2.ebuild b/kde-apps/thumbnailers/thumbnailers-24.02.2.ebuild
new file mode 100644
index 0000000000..aa31df0a46
--- /dev/null
+++ b/kde-apps/thumbnailers/thumbnailers-24.02.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KDE_ORG_NAME="kdegraphics-thumbnailers"
+PVCUT=$(ver_cut 1-3)
+KFMIN=6.0.0
+QTMIN=6.6.2
+inherit ecm gear.kde.org
+
+DESCRIPTION="Thumbnail generators for Mobipocket, PDF/PS and RAW files"
+
+LICENSE="GPL-2+"
+SLOT="6"
+KEYWORDS="~amd64"
+IUSE="mobi raw"
+
+DEPEND="
+ >=dev-qt/qtbase-${QTMIN}:6[gui]
+ >=kde-frameworks/karchive-${KFMIN}:6
+ >=kde-frameworks/kio-${KFMIN}:6
+ mobi? ( >=kde-apps/kdegraphics-mobipocket-${PVCUT}:6 )
+ raw? (
+ >=kde-apps/libkdcraw-${PVCUT}:6
+ >=kde-apps/libkexiv2-${PVCUT}:6
+ )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DDISABLE_MOBIPOCKET=$(usex !mobi)
+ $(cmake_use_find_package raw KExiv2Qt6)
+ $(cmake_use_find_package raw KDcrawQt6)
+ )
+
+ ecm_src_configure
+}