aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-02-01 21:14:55 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2024-02-01 22:19:15 +0100
commit574b92455d9956cbbb40fbbcefce106a44130e07 (patch)
tree4b0d90764e1e490c50968a7e53c67b1562990bbd /net-p2p
parentnet-news/alligator: 24.01.95 version bump (diff)
downloadkde-574b92455d9956cbbb40fbbcefce106a44130e07.tar.gz
kde-574b92455d9956cbbb40fbbcefce106a44130e07.tar.bz2
kde-574b92455d9956cbbb40fbbcefce106a44130e07.zip
net-p2p/ktorrent: 24.01.95 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/ktorrent/Manifest1
-rw-r--r--net-p2p/ktorrent/ktorrent-24.01.95.ebuild89
2 files changed, 90 insertions, 0 deletions
diff --git a/net-p2p/ktorrent/Manifest b/net-p2p/ktorrent/Manifest
index 8aea9fde54..36261842b3 100644
--- a/net-p2p/ktorrent/Manifest
+++ b/net-p2p/ktorrent/Manifest
@@ -1 +1,2 @@
DIST ktorrent-24.01.90.tar.xz 2172872 BLAKE2B 090d1698b60b18e23940f3efc4878253a82af93d50d33d61c8c96c54a805484c0c62f6564b950e1b087f4f2d6149cd3daf381f318531f38b917a4da9417251a2 SHA512 94a4ee2846e40b66c2b4478589a02262f94fddf991573c235bcb7c50fe1cbe35c1e0f8f3d4fb68d1171d69d597563691d3559c6adbd271dcdc4edd77fc567e29
+DIST ktorrent-24.01.95.tar.xz 2173124 BLAKE2B 3c5bf88c2176e985a23f00a65960af2d3a085051635d50751455173528155f208d4189ac88b145bf50a7e3b86eb504bd130a822d9f5bab917d0eb930c83c4556 SHA512 8822911a0c5bd2cd68e7c0a52c06d5f56ec28e97010c99c1e76e66bc19bf54f83aeb431a8fc1ecd95e199f23eda8978ec813bc4a665033d70cbdcc710d0f972e
diff --git a/net-p2p/ktorrent/ktorrent-24.01.95.ebuild b/net-p2p/ktorrent/ktorrent-24.01.95.ebuild
new file mode 100644
index 0000000000..e6f5867bca
--- /dev/null
+++ b/net-p2p/ktorrent/ktorrent-24.01.95.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_HANDBOOK="optional"
+ECM_TEST="optional"
+KFMIN=5.249.0
+PVCUT=$(ver_cut 1-3)
+QTMIN=6.6.0
+inherit ecm gear.kde.org
+
+DESCRIPTION="Powerful BitTorrent client based on KDE Frameworks"
+HOMEPAGE="https://apps.kde.org/ktorrent/"
+
+LICENSE="GPL-2"
+SLOT="6"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+IUSE="+bwscheduler +downloadorder +infowidget +ipfilter +logviewer +magnetgenerator
++mediaplayer rss +scanfolder +shutdown +stats +upnp +webengine +zeroconf"
+
+COMMON_DEPEND="
+ >=dev-qt/qtbase-${QTMIN}:6[dbus,gui,network,widgets,xml]
+ >=kde-frameworks/kcmutils-${KFMIN}:6
+ >=kde-frameworks/kconfig-${KFMIN}:6
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:6
+ >=kde-frameworks/kcoreaddons-${KFMIN}:6
+ >=kde-frameworks/kcrash-${KFMIN}:6
+ >=kde-frameworks/kdbusaddons-${KFMIN}:6
+ >=kde-frameworks/ki18n-${KFMIN}:6
+ >=kde-frameworks/kiconthemes-${KFMIN}:6
+ >=kde-frameworks/kio-${KFMIN}:6
+ >=kde-frameworks/knotifications-${KFMIN}:6
+ >=kde-frameworks/knotifyconfig-${KFMIN}:6
+ >=kde-frameworks/kparts-${KFMIN}:6
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:6
+ >=kde-frameworks/kwindowsystem-${KFMIN}:6
+ >=kde-frameworks/kxmlgui-${KFMIN}:6
+ >=kde-frameworks/solid-${KFMIN}:6
+ >=net-libs/libktorrent-${PVCUT}:6
+ infowidget? ( dev-libs/geoip )
+ ipfilter? ( >=kde-frameworks/karchive-${KFMIN}:6 )
+ mediaplayer? (
+ >=media-libs/phonon-4.12.0[qt6]
+ >=media-libs/taglib-1.5:=
+ )
+ rss? (
+ >=dev-qt/qtwebengine-${QTMIN}:6
+ >=kde-frameworks/syndication-${KFMIN}:6
+ )
+ stats? ( >=kde-frameworks/kplotting-${KFMIN}:6 )
+ upnp? ( >=kde-frameworks/kcompletion-${KFMIN}:6 )
+ webengine? ( >=dev-qt/qtwebengine-${QTMIN}:6 )
+ zeroconf? ( >=kde-frameworks/kdnssd-${KFMIN}:6 )
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-libs/boost-1.71
+"
+RDEPEND="${COMMON_DEPEND}
+ ipfilter? (
+ app-arch/bzip2
+ app-arch/unzip
+ kde-apps/kio-extras:6
+ >=kde-frameworks/ktextwidgets-${KFMIN}:6
+ )
+"
+BDEPEND="sys-devel/gettext"
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_BWSCHEDULER_PLUGIN=$(usex bwscheduler)
+ -DENABLE_DOWNLOADORDER_PLUGIN=$(usex downloadorder)
+ -DENABLE_INFOWIDGET_PLUGIN=$(usex infowidget)
+ -DENABLE_IPFILTER_PLUGIN=$(usex ipfilter)
+ -DENABLE_LOGVIEWER_PLUGIN=$(usex logviewer)
+ -DENABLE_MAGNETGENERATOR_PLUGIN=$(usex magnetgenerator)
+ -DENABLE_MEDIAPLAYER_PLUGIN=$(usex mediaplayer)
+ $(cmake_use_find_package rss KF6Syndication)
+ -DENABLE_SCANFOLDER_PLUGIN=$(usex scanfolder)
+ -DENABLE_SHUTDOWN_PLUGIN=$(usex shutdown)
+ -DENABLE_STATS_PLUGIN=$(usex stats)
+ -DENABLE_UPNP_PLUGIN=$(usex upnp)
+ -DENABLE_SEARCH_PLUGIN=$(usex webengine)
+ -DENABLE_ZEROCONF_PLUGIN=$(usex zeroconf)
+ )
+# add back when ported
+# -DENABLE_WEBINTERFACE_PLUGIN=$(usex webinterface)
+ ecm_src_configure
+}