summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--0000_README4
-rw-r--r--1101_linux-4.4.102.patch43
2 files changed, 47 insertions, 0 deletions
diff --git a/0000_README b/0000_README
index c2f7291b..069312b9 100644
--- a/0000_README
+++ b/0000_README
@@ -447,6 +447,10 @@ Patch: 1100_linux-4.4.101.patch
From: http://www.kernel.org
Desc: Linux 4.4.101
+Patch: 1101_linux-4.4.102.patch
+From: http://www.kernel.org
+Desc: Linux 4.4.102
+
Patch: 1500_XATTR_USER_PREFIX.patch
From: https://bugs.gentoo.org/show_bug.cgi?id=470644
Desc: Support for namespace user.pax.* on tmpfs.
diff --git a/1101_linux-4.4.102.patch b/1101_linux-4.4.102.patch
new file mode 100644
index 00000000..45e56d17
--- /dev/null
+++ b/1101_linux-4.4.102.patch
@@ -0,0 +1,43 @@
+diff --git a/Makefile b/Makefile
+index 0d7b050427ed..9e036fac9c04 100644
+--- a/Makefile
++++ b/Makefile
+@@ -1,6 +1,6 @@
+ VERSION = 4
+ PATCHLEVEL = 4
+-SUBLEVEL = 101
++SUBLEVEL = 102
+ EXTRAVERSION =
+ NAME = Blurry Fish Butt
+
+diff --git a/mm/debug-pagealloc.c b/mm/debug-pagealloc.c
+index fe1c61f7cf26..3b8f1b83610e 100644
+--- a/mm/debug-pagealloc.c
++++ b/mm/debug-pagealloc.c
+@@ -34,7 +34,7 @@ static inline void set_page_poison(struct page *page)
+ struct page_ext *page_ext;
+
+ page_ext = lookup_page_ext(page);
+- if (page_ext)
++ if (!page_ext)
+ return;
+ __set_bit(PAGE_EXT_DEBUG_POISON, &page_ext->flags);
+ }
+@@ -44,7 +44,7 @@ static inline void clear_page_poison(struct page *page)
+ struct page_ext *page_ext;
+
+ page_ext = lookup_page_ext(page);
+- if (page_ext)
++ if (!page_ext)
+ return;
+ __clear_bit(PAGE_EXT_DEBUG_POISON, &page_ext->flags);
+ }
+@@ -54,7 +54,7 @@ static inline bool page_poison(struct page *page)
+ struct page_ext *page_ext;
+
+ page_ext = lookup_page_ext(page);
+- if (page_ext)
++ if (!page_ext)
+ return false;
+ return test_bit(PAGE_EXT_DEBUG_POISON, &page_ext->flags);
+ }