summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChema Alonso Josa <nimiux@gentoo.org>2016-12-01 23:47:28 +0100
committerChema Alonso Josa <nimiux@gentoo.org>2018-03-09 22:33:53 +0100
commit8ed42a1e6df5ff42c99a0d81b462b2071d623613 (patch)
tree46eb3754fa5c151348de721f34bdc808f915a98c /dev-lisp/cl-graph
parentdev-lisp/local-time: Bumps version to 1.0.6 (diff)
downloadlisp-8ed42a1e6df5ff42c99a0d81b462b2071d623613.tar.gz
lisp-8ed42a1e6df5ff42c99a0d81b462b2071d623613.tar.bz2
lisp-8ed42a1e6df5ff42c99a0d81b462b2071d623613.zip
dev-lisp/cl-graph: Updates header, EAPI and SRC_URI
Diffstat (limited to 'dev-lisp/cl-graph')
-rw-r--r--dev-lisp/cl-graph/Manifest6
-rw-r--r--dev-lisp/cl-graph/cl-graph-0.10.2.ebuild27
-rw-r--r--dev-lisp/cl-graph/files/cl-graph-0.10.2-fix-deps.patch (renamed from dev-lisp/cl-graph/files/fix-deps.patch)40
3 files changed, 40 insertions, 33 deletions
diff --git a/dev-lisp/cl-graph/Manifest b/dev-lisp/cl-graph/Manifest
index fadaddba..07cc9f20 100644
--- a/dev-lisp/cl-graph/Manifest
+++ b/dev-lisp/cl-graph/Manifest
@@ -1,3 +1,3 @@
-AUX fix-deps.patch 1862 RMD160 46f6475d52a63373d6e8f35e9fe8c2854da0afce SHA1 57609272cf529b653a91fe3eb435f40b49943826 SHA256 ad12bd920002e62572e11e2746cf2885335b2253f7fbb78e0b2af2c123972b44
-DIST cl-graph-0.10.2.tar.bz2 45653 RMD160 67ef6924d014fd5225a27d0234468034286c6052 SHA1 4f83c11b5e36f420f855207584173b87e5eaef1d SHA256 76c993d6aea0b7ce51397ccf445e825fb1914ed47502a0e43415e41242ab0da5
-EBUILD cl-graph-0.10.2.ebuild 845 RMD160 519e65d708d00c6c0225a83c4e200d406e80fa04 SHA1 a34cc7e7fdf6b0ba2cc1c5fb4fe61806c47adcf0 SHA256 c43d6cd860530d9b77d50c7dad0c64182d6cd2a257b929b088269bd4753d9bde
+AUX cl-graph-0.10.2-fix-deps.patch 1550 SHA256 f5710a47d039e50e27264c6365ee3ccade376fbdc25694b6de5dfdb34cd803df SHA512 00c265829cea603fef98fbb9adb3b68d1321cb66d70ea8f719bf34e9795a3cc6133d4b4970f734f779de7ee5b1c0a6a2b245e91718e3067ed9ed17a2a396bb6a WHIRLPOOL b10bee9057b111065d973a9f1634f9875c983b5476e7329f87a43054be26b6518cfd3cd010f6146c8a00dbf150db9169e1f9bcfa8bf3ebd46b3bdae8e28f7675
+DIST version-0.10.2.tar.gz 59273 SHA256 3a52892e828c918c53e591e250be31c1505b8f1e1be2e0e400e9e5d00292b95b SHA512 d41ac3de7fc41dae97161415581f7c846d9e1955f61230e6ae2a7f365ccf25673ba2c400729e647e32cb685d522d9a89bc79f2c28d2ed5491ef77cf11fac2a61 WHIRLPOOL 52541c73992c40529d7277ed844bb49c94e07a27fcb3a472c17710bc103b6339df4aa8be06270374aa29c1f38ba2ec93b0dacc18678d867f94424183ff81ba3d
+EBUILD cl-graph-0.10.2.ebuild 928 SHA256 9895204a36dd803f6b51d4f5f799a4bf195984a4e18ad4b1a62e22371c03085c SHA512 14febb2c7469173a4825bd71516968895e428efa7d1f020c953e81c73cf0d32a8ac95bce0537d45ad123c4faaa74e56b4c0446cdcea6c979aeec1f4d5522cbe4 WHIRLPOOL eec71125f2bb34180b45ba2c6a220f39411764f45ddfa2e3bfa6d03b31296c9e723aa86046213f1855c7d83a1f50b51309493188d2df41559ab2c4ad1803a56e
diff --git a/dev-lisp/cl-graph/cl-graph-0.10.2.ebuild b/dev-lisp/cl-graph/cl-graph-0.10.2.ebuild
index f2c271bb..bf7dff90 100644
--- a/dev-lisp/cl-graph/cl-graph-0.10.2.ebuild
+++ b/dev-lisp/cl-graph/cl-graph-0.10.2.ebuild
@@ -1,17 +1,21 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: $
+# $Id$
-inherit common-lisp-2 eutils
+EAPI=6
+
+inherit common-lisp-3 eutils
+
+MY_PV="version-${PV}"
DESCRIPTION="Graph manipulation utilities for Common Lisp."
HOMEPAGE="http://common-lisp.net/project/cl-graph"
-SRC_URI="http://common-lisp.net/~sionescu/files/${P}.tar.bz2"
+SRC_URI="https://github.com/gwkkwg/${PN}/archive/${MY_PV}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-IUSE=""
+IUSE="doc"
RDEPEND="dev-lisp/asdf-system-connections
>=dev-lisp/metatilities-base-0.6.0
@@ -22,13 +26,16 @@ RDEPEND="dev-lisp/asdf-system-connections
CLSYSTEMS="${PN} ${PN}-test"
-src_unpack() {
- unpack ${A} && cd "${S}"
- epatch "${FILESDIR}"/fix-deps.patch
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-fix-deps.patch
+ default
}
src_install() {
- common-lisp-install *.asd dev/{*.lisp,graphviz} unit-tests
- common-lisp-symlink-asdf
+ common-lisp-install-sources dev/{*.lisp,graphviz} unit-tests
+ common-lisp-install-asdf
+ use doc && dodoc -r website
docinto examples && dodoc dev/examples/*
}
diff --git a/dev-lisp/cl-graph/files/fix-deps.patch b/dev-lisp/cl-graph/files/cl-graph-0.10.2-fix-deps.patch
index fbcfa1a4..bd639c3f 100644
--- a/dev-lisp/cl-graph/files/fix-deps.patch
+++ b/dev-lisp/cl-graph/files/cl-graph-0.10.2-fix-deps.patch
@@ -3,22 +3,22 @@ Date: 2008-10-28
Status: Gentoo-only
Description: Add hard dep on moptilities and include subgraph-containing in main system
-diff -Naur cl-graph-0.10.2.orig/cl-graph.asd cl-graph-0.10.2/cl-graph.asd
---- cl-graph-0.10.2.orig/cl-graph.asd 2008-10-28 16:22:05.000000000 +0100
-+++ cl-graph-0.10.2/cl-graph.asd 2008-10-28 16:45:46.000000000 +0100
-@@ -32,8 +32,10 @@
- :depends-on ("graph"))
- (:file "graph-matrix"
- :depends-on ("graph"))
-- (:file "graph-algorithms"
-+ (:file "subgraph-containing"
- :depends-on ("graph"))
-+ (:file "graph-algorithms"
-+ :depends-on ("graph" "subgraph-containing"))
- (:module "graphviz" :depends-on ("graph")
- :components ((:file "graphviz-support"))))))
- :in-order-to ((test-op (load-op :cl-graph-test)))
-@@ -42,8 +44,10 @@
+diff -Nuar a/cl-graph.asd b/cl-graph.asd
+--- a/cl-graph.asd 2008-10-27 02:00:50.000000000 +0100
++++ b/cl-graph.asd 2016-12-01 23:35:27.710005029 +0100
+@@ -33,8 +33,10 @@
+ :depends-on ("graph"))
+ (:file "graph-matrix"
+ :depends-on ("graph"))
+- (:file "graph-algorithms"
++ (:file "subgraph-containing"
+ :depends-on ("graph"))
++ (:file "graph-algorithms"
++ :depends-on ("graph" "subgraph-containing"))
+
+ (:static-file "notes.text")
+
+@@ -51,8 +53,10 @@
(intern (symbol-name '#:run-tests) :lift)
:config :generic))
:depends-on ((:version :metatilities-base "0.6.0")
@@ -29,15 +29,15 @@ diff -Naur cl-graph-0.10.2.orig/cl-graph.asd cl-graph-0.10.2/cl-graph.asd
+ (:version :cl-containers "0.11.0")
+ ))
- (defmethod operation-done-p
+ (defmethod operation-done-p
((o test-op) (c (eql (find-system 'cl-graph))))
-@@ -85,14 +89,6 @@
+@@ -94,14 +98,6 @@
((:file "graph-metrics")))))
#+asdf-system-connections
-(asdf:defsystem-connection cl-graph-and-moptilities
- :requires (cl-graph moptilities)
-- :components ((:module
+- :components ((:module
- "dev"
- :components
- ((:file "subgraph-containing")))))
@@ -45,4 +45,4 @@ diff -Naur cl-graph-0.10.2.orig/cl-graph.asd cl-graph-0.10.2/cl-graph.asd
-#+asdf-system-connections
(asdf:defsystem-connection cl-graph-and-dynamic-classes
:requires (cl-graph dynamic-classes)
- :components ((:module
+ :components ((:module