summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStelian Ionescu <sionescu@common-lisp.net>2008-05-03 18:07:13 +0200
committerStelian Ionescu <sionescu@common-lisp.net>2008-05-03 18:07:13 +0200
commit390d64d9b358c3e86bdc71c8bb5ea4ac86f878c1 (patch)
tree5d9c211361c43782b251f16aaed9a2d0a73c29c8 /dev-lisp/cl-launch
parentmodified larceny-0.95 ebuild for 0.961, testing/editing still needed (diff)
downloadlisp-390d64d9b358c3e86bdc71c8bb5ea4ac86f878c1.tar.gz
lisp-390d64d9b358c3e86bdc71c8bb5ea4ac86f878c1.tar.bz2
lisp-390d64d9b358c3e86bdc71c8bb5ea4ac86f878c1.zip
Added dev-lisp/cl-launch-2.07
Signed-off-by: Stelian Ionescu <sionescu@common-lisp.net>
Diffstat (limited to 'dev-lisp/cl-launch')
-rw-r--r--dev-lisp/cl-launch/Manifest2
-rw-r--r--dev-lisp/cl-launch/cl-launch-2.07.ebuild18
2 files changed, 20 insertions, 0 deletions
diff --git a/dev-lisp/cl-launch/Manifest b/dev-lisp/cl-launch/Manifest
new file mode 100644
index 00000000..ab80609e
--- /dev/null
+++ b/dev-lisp/cl-launch/Manifest
@@ -0,0 +1,2 @@
+DIST cl-launch_2.07.tar.gz 47601 RMD160 70c81662bdefa86ef26aa0cf5cbd4ce7a98114f5 SHA1 1f52bdc798433f72fcd9055891cd919bfc8f9601 SHA256 c78f2520d2ed87a6102b9a578082571af09846929e1e60847e89c168f60f1912
+EBUILD cl-launch-2.07.ebuild 571 RMD160 0b32d92eb6dad5a5a73109015e298f410baac48f SHA1 ec2efdaac93dfb14600c1de985a865e797e388fb SHA256 e5724d765740685c76947c7c4c17d8c5ffc6b03da902e40853f967acea7314a0
diff --git a/dev-lisp/cl-launch/cl-launch-2.07.ebuild b/dev-lisp/cl-launch/cl-launch-2.07.ebuild
new file mode 100644
index 00000000..850f6070
--- /dev/null
+++ b/dev-lisp/cl-launch/cl-launch-2.07.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit common-lisp-2
+
+DESCRIPTION="cl-launch is a utility to make Common Lisp software easily invokable from the command-line."
+HOMEPAGE="http://www.cliki.net/cl-launch"
+SRC_URI="http://fare.tunes.org/files/cl-launch/cl-launch_${PV}.tar.gz"
+LICENSE="No-Problem-Bugroff LLGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+src_install() {
+ dobin cl-launch.sh
+ common-lisp-install launcher.lisp wrapper.sh cl-launch.asd
+ common-lisp-symlink-asdf
+}