summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStelian Ionescu <sionescu@cddr.org>2010-12-16 23:43:50 +0100
committerChema Alonso Josa <nimiux@gentoo.org>2018-03-09 22:33:27 +0100
commit31c3bc9e3a6eea4a5e5968bd769c8d15deb10797 (patch)
tree6d78f452625670a72b2e3fd95d4ddf1ae079759e /dev-lisp
parentAdd dev-lisp/lispbuilder-sdl-ttf-0.3.0 (diff)
downloadlisp-31c3bc9e3a6eea4a5e5968bd769c8d15deb10797.tar.gz
lisp-31c3bc9e3a6eea4a5e5968bd769c8d15deb10797.tar.bz2
lisp-31c3bc9e3a6eea4a5e5968bd769c8d15deb10797.zip
dev-lisp/clx: add patch to work around a compiler bug in SBCL 1.0.45, bump to 0.7.4-r1
SBCL 1.0.45 has a bug in handling dynamic-extent args, truggered by CLX::SEND-REQUEST
Diffstat (limited to 'dev-lisp')
-rw-r--r--dev-lisp/clx/Manifest3
-rw-r--r--dev-lisp/clx/clx-0.7.4-r1.ebuild (renamed from dev-lisp/clx/clx-0.7.4.ebuild)16
2 files changed, 8 insertions, 11 deletions
diff --git a/dev-lisp/clx/Manifest b/dev-lisp/clx/Manifest
index 39c49c02..659382f4 100644
--- a/dev-lisp/clx/Manifest
+++ b/dev-lisp/clx/Manifest
@@ -1,6 +1,7 @@
AUX gentoo-fix-asd.patch 11298 RMD160 41bbbee1825a9a414f62507c3ab28129f2adca6b SHA1 c9533f31bf0617af87a4e81cf2784b1b3ab98130 SHA256 9a9fe8c95020cbadbac7f283ce37abd346d550f9136d53807e8138e58534120d
AUX gentoo-fix-dep-openmcl.patch 905 RMD160 4ea7a036098b48d56874acb80d18c512338877e7 SHA1 e886ec80bcc2fc4eb05e838fe72bf901b5d4104b SHA256 c3d06020eb70df215de7b72b29af207d45239c908e3d0149ca8a3e40c6e70d76
+AUX gentoo-fix-dynamic-extent-sbcl-1.0.45.patch 600 RMD160 8e56bb57f760739af4a65161db091f0395d6786e SHA1 1f85ff4ed51405ee9dfdc297febf7eaafe319eb7 SHA256 f3925863e607b5ec2bc96f891b11b89818feb5c17d985766c7c0e69e098000fd
AUX gentoo-fix-obsolete-eval-when.patch 435 RMD160 c208408d4e99edb78947a8f7d06a7deffdcaba40 SHA1 951801fc5a86ae870a38c71e6ee4829f2f4e5691 SHA256 7c7b3d17102223a6f0c24d31e7942880977ba4de422b51d189fac9c8a298c197
AUX gentoo-fix-unused-vars.patch 3139 RMD160 3ba5c532207d33d0faf7675a7bc534746c7af485 SHA1 fc92acecb9d2e65f752658060c2b33a03e4b07ad SHA256 08a548efa8d7c69b41cf208a16efd42cf78aebaf3f529aa6b35f23ecfacd0b57
DIST clx-0.7.4.tgz 444490 RMD160 12a1b87cc1b735c56dbaa2f152f522ae1d817c0b SHA1 0421233f53b244aba636832cfed7946f7e7286ad SHA256 4a80f80255ace26eb8df214957dda3d7b7e51955537405ec893a34b18e569028
-EBUILD clx-0.7.4.ebuild 1237 RMD160 52e7eccdfb872173bb1743fa7f1994a3f3d48045 SHA1 8b61a679be71cd16a917e516ad054886d9790eab SHA256 34b99e4ff84729bf1fd1db832ac8ffeef9210e8bf86bd82f6b1fd3b5e0f3d028
+EBUILD clx-0.7.4-r1.ebuild 1264 RMD160 3483b218d0faf09b25b931643ca2f32bec87cd6d SHA1 f7ad57bdcda74fc2d046e22284faa0937cefc3f9 SHA256 936b04499577e9b65562eb167ccdddd562e47618af62dd063ca48ec82548dd50
diff --git a/dev-lisp/clx/clx-0.7.4.ebuild b/dev-lisp/clx/clx-0.7.4-r1.ebuild
index 11dc883e..513a5b75 100644
--- a/dev-lisp/clx/clx-0.7.4.ebuild
+++ b/dev-lisp/clx/clx-0.7.4-r1.ebuild
@@ -2,8 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI=2
-inherit common-lisp-2 eutils
+EAPI=3
+inherit common-lisp-3 eutils
DESCRIPTION="CLX is the Common Lisp interface to the X11 protocol primarily for SBCL."
HOMEPAGE="http://www.cliki.net/CLX"
@@ -18,17 +18,13 @@ DEPEND="sys-apps/texinfo
doc? ( virtual/texi2dvi )"
RDEPEND="!dev-lisp/cl-${PN}"
-src_unpack() {
- unpack ${A}
- cd "${S}"
- rm {exclcmac,sockcl,defsystem,provide,cmudep}.lisp
-}
-
src_prepare() {
+ rm -v {exclcmac,sockcl,defsystem,provide,cmudep}.lisp || die
epatch "${FILESDIR}"/gentoo-fix-asd.patch
epatch "${FILESDIR}"/gentoo-fix-dep-openmcl.patch
epatch "${FILESDIR}"/gentoo-fix-unused-vars.patch
epatch "${FILESDIR}"/gentoo-fix-obsolete-eval-when.patch
+ epatch "${FILESDIR}"/gentoo-fix-dynamic-extent-sbcl-1.0.45.patch
}
src_compile() {
@@ -41,8 +37,8 @@ src_compile() {
}
src_install() {
- common-lisp-install *.{lisp,asd} {debug,demo,test}/*.lisp
- common-lisp-symlink-asdf
+ common-lisp-install-sources *.lisp debug demo test
+ common-lisp-install-asdf
dodoc NEWS CHANGES README*
doinfo manual/${PN}.info
use doc && dodoc manual/${PN}.pdf