summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVadim A. Misbakh-Soloviov <git@mva.name>2019-01-06 01:47:41 +0700
committerVadim A. Misbakh-Soloviov <git@mva.name>2019-01-06 01:47:41 +0700
commit3cc8b2e8c540c06124d01d9b1c084900c7d02f49 (patch)
tree3203e4c75b26c81d1874e66531efe53e9866eebc
parentmsgpack: bye (diff)
downloadlua-3cc8b2e8c540c06124d01d9b1c084900c7d02f49.tar.gz
lua-3cc8b2e8c540c06124d01d9b1c084900c7d02f49.tar.bz2
lua-3cc8b2e8c540c06124d01d9b1c084900c7d02f49.zip
moo
Signed-off-by: Vadim A. Misbakh-Soloviov <git@mva.name>
-rw-r--r--dev-lua/lua-ext/lua-ext-9999.ebuild2
-rw-r--r--dev-lua/lua-html/lua-html-9999.ebuild4
-rw-r--r--dev-lua/lua-udev/files/patches/9999/newlib.patch15
-rw-r--r--dev-lua/lua-udev/lua-udev-9999.ebuild35
-rw-r--r--dev-lua/lua-udev/metadata.xml14
-rw-r--r--dev-lua/luaevent/luaevent-9999.ebuild2
-rw-r--r--dev-lua/luaunbound/luaunbound-9999.ebuild12
-rw-r--r--dev-lua/lvk/lvk-9999.ebuild23
-rw-r--r--dev-lua/moses/moses-9999.ebuild2
-rw-r--r--dev-lua/penlight/penlight-9999.ebuild6
10 files changed, 103 insertions, 12 deletions
diff --git a/dev-lua/lua-ext/lua-ext-9999.ebuild b/dev-lua/lua-ext/lua-ext-9999.ebuild
index 5423ec4..1ef6344 100644
--- a/dev-lua/lua-ext/lua-ext-9999.ebuild
+++ b/dev-lua/lua-ext/lua-ext-9999.ebuild
@@ -24,7 +24,7 @@ RDEPEND="
)
"
-DOCS=(README)
+DOCS=(README.md)
each_lua_install() {
use gcmem || rm gcmem.lua
diff --git a/dev-lua/lua-html/lua-html-9999.ebuild b/dev-lua/lua-html/lua-html-9999.ebuild
index dfa3870..213eed0 100644
--- a/dev-lua/lua-html/lua-html-9999.ebuild
+++ b/dev-lua/lua-html/lua-html-9999.ebuild
@@ -23,7 +23,7 @@ RDEPEND="
dev-libs/libxml2
"
-DOCS=(Readme.md)
+DOCS=(README.md)
all_lua_prepare() {
lua_default
@@ -37,6 +37,8 @@ all_lua_prepare() {
sed -r \
-e 's#libxml/HTMLParser.h#libxml/HTMLparser.h#' \
-i html.c
+
+ mv Readme.md README.md
}
each_lua_test() {
diff --git a/dev-lua/lua-udev/files/patches/9999/newlib.patch b/dev-lua/lua-udev/files/patches/9999/newlib.patch
new file mode 100644
index 0000000..0e3c7cf
--- /dev/null
+++ b/dev-lua/lua-udev/files/patches/9999/newlib.patch
@@ -0,0 +1,15 @@
+--- a/lua-udev.c 2018-09-25 18:34:57.043484722 +0700
++++ b/lua-udev.c 2018-09-25 18:38:32.437294642 +0700
+@@ -584,10 +584,9 @@ static luaL_Reg udev_methods[] = {
+
+ };
+
+-#if LUA_VERSION_NUM < 503
++#ifndef luaL_newlib
+ #define luaL_newlib(L, methods)\
+- lua_createtable(L, 0, sizeof(methods) / sizeof(luaL_Reg) - 1);\
++ lua_createtable(L, 0, sizeof(methods) / sizeof(luaL_Reg) - 1);
+- luaL_register(L, NULL, methods);
+ #endif
+
+ #define lua_pushcfunctionfield(field, method)\
diff --git a/dev-lua/lua-udev/lua-udev-9999.ebuild b/dev-lua/lua-udev/lua-udev-9999.ebuild
new file mode 100644
index 0000000..a65be4d
--- /dev/null
+++ b/dev-lua/lua-udev/lua-udev-9999.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+IS_MULTILIB=true
+VCS="git"
+GITHUB_A="dodo"
+
+inherit lua
+
+DESCRIPTION="udev bindings for Lua"
+HOMEPAGE="https://github.com/dodo/lua-udev/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS=""
+IUSE="examples"
+
+EXAMPLES=(test.lua)
+
+RDEPEND=""
+DEPEND="
+ ${RDEPEND}
+ virtual/libudev
+"
+
+each_lua_compile() {
+ _lua_setFLAGS
+ ${CC} "${PN}.c" ${CFLAGS} ${LUA_CF} ${LDFLAGS} ${LUA_LF} -ludev -o udev.so
+}
+
+each_lua_install() {
+ dolua udev.so
+}
diff --git a/dev-lua/lua-udev/metadata.xml b/dev-lua/lua-udev/metadata.xml
new file mode 100644
index 0000000..c1baef2
--- /dev/null
+++ b/dev-lua/lua-udev/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>williamh@gentoo.org</email>
+ <name>William Hubbs</name>
+ </maintainer>
+ <longdescription lang="en">
+ lightweight, native, lazy evaluating multithreading library for Lua-5.1 or 5.2.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">LuaLanes/lanes</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-lua/luaevent/luaevent-9999.ebuild b/dev-lua/luaevent/luaevent-9999.ebuild
index b9cc916..bf72d8b 100644
--- a/dev-lua/luaevent/luaevent-9999.ebuild
+++ b/dev-lua/luaevent/luaevent-9999.ebuild
@@ -25,8 +25,6 @@ DEPEND="
DOCS=(README)
-PATCHES=(${FILESDIR}/gc-anchoring.patch)
-
each_lua_install() {
dolua lua/*
_dolua_insdir="${PN}" \
diff --git a/dev-lua/luaunbound/luaunbound-9999.ebuild b/dev-lua/luaunbound/luaunbound-9999.ebuild
index 2f6e813..5662070 100644
--- a/dev-lua/luaunbound/luaunbound-9999.ebuild
+++ b/dev-lua/luaunbound/luaunbound-9999.ebuild
@@ -26,9 +26,13 @@ DEPEND="
DOCS=(README.markdown)
-#all_lua_prepare() {
-#
-#}
+all_lua_prepare() {
+ lua_default
+ sed -r \
+ -e "/^LUA_VERSION/s@5.2@\$\(LUA_IMPL\)\nLD=gcc@" \
+ -e "/^CFLAGS/s@lua-@@" \
+ -i GNUmakefile
+}
each_lua_compile() {
# If we have LuaJIT in the system — we'd prefer FFI version
@@ -50,7 +54,7 @@ each_lua_install() {
if use prosody; then
insinto "/etc/jabber"
- doins "use_unbound.lua"
+ doins "use_unbound.lua"
fi
}
diff --git a/dev-lua/lvk/lvk-9999.ebuild b/dev-lua/lvk/lvk-9999.ebuild
new file mode 100644
index 0000000..1cfd219
--- /dev/null
+++ b/dev-lua/lvk/lvk-9999.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+VCS="git"
+GITHUB_A="gleb-kosteiko"
+
+inherit lua
+
+DESCRIPTION="Parse HTML text into a tree of elements with selectors"
+HOMEPAGE="https://github.com/msva/lua-htmlparser"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS=""
+IUSE="examples"
+
+EXAMPLES=( test-lvk.lua )
+
+each_lua_install() {
+ dolua "${PN}".lua
+}
diff --git a/dev-lua/moses/moses-9999.ebuild b/dev-lua/moses/moses-9999.ebuild
index 7d43abb..0b182c5 100644
--- a/dev-lua/moses/moses-9999.ebuild
+++ b/dev-lua/moses/moses-9999.ebuild
@@ -25,7 +25,7 @@ DEPEND="
"
DOCS=(README.md doc/tutorial.md)
-HTML_DOCS=(doc/index.html doc/topics)
+HTML_DOCS=(doc/index.html doc/manual)
each_lua_install() {
dolua ${PN}.lua
diff --git a/dev-lua/penlight/penlight-9999.ebuild b/dev-lua/penlight/penlight-9999.ebuild
index 9ceebc0..ddb5ba6 100644
--- a/dev-lua/penlight/penlight-9999.ebuild
+++ b/dev-lua/penlight/penlight-9999.ebuild
@@ -8,7 +8,7 @@ GITHUB_A="stevedonovan"
inherit lua
-DESCRIPTION="A set of pure Lua libraries focusing on input data handling, functional programming and OS path management."
+DESCRIPTION="Libraries for input handling, functional programming and OS path management."
HOMEPAGE="https://github.com/stevedonovan/Penlight"
LICENSE="MIT"
@@ -23,8 +23,8 @@ DEPEND="
doc? ( dev-lua/ldoc )
"
-HTML_DOCS=(html/.)
-DOCS=(README.md CHANGES.md CONTRIBUTING.md)
+#HTML_DOCS=(html/.)
+DOCS=(README.md CONTRIBUTING.md)
EXAMPLES=(examples/.)
all_lua_compile() {