aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Harring <ferringb@gmail.com>2024-01-24 22:32:57 -0800
committerArthur Zamarin <arthurzam@gentoo.org>2024-01-26 11:34:40 +0200
commitb9cd84c03bd2140f5373418148ae307dd40ae658 (patch)
tree405c73613bc5b888c4713a0156b18a0a7978d8ce
parentci: bump dependencies (diff)
downloadpkgcore-b9cd84c03bd2140f5373418148ae307dd40ae658.tar.gz
pkgcore-b9cd84c03bd2140f5373418148ae307dd40ae658.tar.bz2
pkgcore-b9cd84c03bd2140f5373418148ae307dd40ae658.zip
fix: tox.ini since it's not been used in ages.
This broken whenever the repo went to pyproject.toml . On the one hand, I like enumerating what devs have to invoke locally rather than relying on GH. On the other hand, clearly no one is using this. This fixes it for current usage. If it's to continue, then GH and tox envlist's should be fused. Signed-off-by: Brian Harring <ferringb@gmail.com> Closes: https://github.com/pkgcore/pkgcore/pull/430 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--tox.ini9
1 files changed, 3 insertions, 6 deletions
diff --git a/tox.ini b/tox.ini
index 3a87db95..4bc6bce3 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,25 +1,22 @@
[tox]
-envlist = py38, py39, py310, py311, py312
+envlist = py310, py311, py312
[testenv]
# force latest virtualenv/pip
download = true
-deps = -rrequirements/tox.txt
+extras = test
commands =
pytest --cov {posargs:-v}
# build docs
[testenv:docs]
skip_install = true
-deps =
- -rrequirements/dev.txt
- -rrequirements/docs.txt
+extras = doc
commands =
python setup.py build_docs
# build dist files
[testenv:dist]
skip_install = true
-deps = -rrequirements/dist.txt
commands =
python setup.py sdist
python setup.py bdist_wheel