aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gmail.com>2014-10-27 01:29:24 -0400
committerTim Harder <radhermit@gmail.com>2014-10-27 01:42:32 -0400
commitac8c2818a6bc858fa9f46faebb397cf283110030 (patch)
treeed4ebe72fdf0b0007a85bdc12bb8d15cfc06ac29 /README.rst
parentRevert "travis-ci: force pylint testing against the installed module" (diff)
downloadsnakeoil-ac8c2818a6bc858fa9f46faebb397cf283110030.tar.gz
snakeoil-ac8c2818a6bc858fa9f46faebb397cf283110030.tar.bz2
snakeoil-ac8c2818a6bc858fa9f46faebb397cf283110030.zip
convert NEWS and README into rst files
This allows use to use the github renderer to show a better README file by default and deprecate/drop the usage of the custom txt -> rst news generation method for building the docs.
Diffstat (limited to 'README.rst')
-rw-r--r--README.rst50
1 files changed, 50 insertions, 0 deletions
diff --git a/README.rst b/README.rst
new file mode 100644
index 0000000..41a3b6e
--- /dev/null
+++ b/README.rst
@@ -0,0 +1,50 @@
+========
+snakeoil
+========
+
+snakeoil is a python library that implements optimized versions of common
+python functionality. Some classes and functions have cpython equivalents,
+but they all have native python implementations too.
+
+
+Contact
+=======
+
+Please create an issue in the `issue tracker`_.
+
+
+Tests
+=====
+
+A standalone test runner is integrated in setup.py; to run, just execute
+setup.py test
+Aside from that, our runner of choice is twisteds trial; ran via-
+
+trial snakeoil
+
+if you're doing development, trial is significantly friendlier; the
+standalone runner is designed to be used mainly for installations of
+snakeoil, where all tests must pass, else installation is aborted.
+
+
+Installing
+==========
+
+pretty simple-
+
+tar jxf snakeoil-0.XX.tar.bz2
+cd snakeoil-0.XX
+python setup.py build
+
+if after running tests,
+
+cd snakeoil-0.xx
+python setup.py test
+
+finally, installing-
+
+cd snakeoil-0.xx
+python setup.py install
+
+
+.. _`issue tracker`: https://github.com/pkgcore/snakeoil/issues