aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetr Vaněk <arkamar@atlas.cz>2023-05-31 10:36:01 +0200
committerSam James <sam@gentoo.org>2023-05-31 21:13:10 +0100
commit6d28f00f48078ccb2b49547258cc3076c8c3c9b0 (patch)
treee981ed2a4292ccdab36f16d69561308140ed943c
parentMakefile.gpyutils: enable .dot file for 3.12 (diff)
downloadqa-scripts-6d28f00f48078ccb2b49547258cc3076c8c3c9b0.tar.gz
qa-scripts-6d28f00f48078ccb2b49547258cc3076c8c3c9b0.tar.bz2
qa-scripts-6d28f00f48078ccb2b49547258cc3076c8c3c9b0.zip
Makefile.gpyutils: enable py3.12 graphs
They generate within reasonable time frame, ~17 mins in my case. Signed-off-by: Petr Vaněk <arkamar@atlas.cz> Closes: https://github.com/gentoo/qa-scripts/pull/3 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--Makefile.gpyutils4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.gpyutils b/Makefile.gpyutils
index cb228c7..51e56c2 100644
--- a/Makefile.gpyutils
+++ b/Makefile.gpyutils
@@ -15,11 +15,11 @@ upgr_base = $(outdir)/310-to-311.txt
# related stabilizations
upgr_streq = $(patsubst %.txt,%-stablereq.txt,$(upgr_base))
# all upgrade stuff
-upgr_txt = $(upgr_base) $(upgr_streq)
+upgr_txt = $(upgr_base) $(upgr_streq) $(outdir)/311-to-312.txt
upgr_dot = $(patsubst %.txt,%.dot,$(upgr_txt))
upgr_svg = $(patsubst %.dot,%.svg,$(upgr_dot))
# add new impls here if not stable yet, to avoid insanely huge generation times
-upgr_all = $(upgr_txt) $(upgr_dot) $(upgr_svg) $(outdir)/311-to-312.txt $(outdir)/311-to-312.dot
+upgr_all = $(upgr_txt) $(upgr_dot) $(upgr_svg)
all = $(upgr_all)